Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Medium Load Member hunts2much's Avatar
    Member Since
    Aug 2008
    Location
    Michigan
    Trucker?
    4 Years
    Posts
    303
    Thanks
    296
    Thanked: 97 Times

    high swr with K40 not stock antenna

    Ok, I bought a Cobra 29 (black chrome) from Sparkys CB Shack with good cable and a K40 antenna. Sparky talked me out of the Wilson 2000 antenna and into the K40 btw, despite what I've read, but anyway back on topic... I'm having some issues tuning the antenna.



    With the K40 hooked up I am getting a swr reading over 3 to 1. If I simply hook the stock Volvo antenna back up I get a pretty flat 1.2 to 1 all the way across the band. What gives? Defective antenna or operator error?

  2. #2
    Road Train Member
    Member Since
    Aug 2008
    Location
    Rats nest Grafton North Dakota
    Trucker?
    10 Years
    Age
    47
    Posts
    1,504
    Thanks
    313
    Thanked: 1,389 Times
    The K40 is adjustable. Move the whip up or down to get the best swr. If going up makes the swr worse then you need to go down with it. You may have to remove the whip and clip some off the bottom of it till you get the best swr. No more then 1/4 inch at a time.

    I have found that the stock antenna system on the newer volvos is not to bad actually. I run with alot of these newer volvos since alot of our companies fleet is Volvo with the exception of a few petes and KWs. Alot of the ones I run with have pretty good reception and transmit distance. Just don't push much power through the stock system on the Volvos because the multiplexer box will go out.

  3. #3
    Medium Load Member hunts2much's Avatar
    Member Since
    Aug 2008
    Location
    Michigan
    Trucker?
    4 Years
    Posts
    303
    Thanks
    296
    Thanked: 97 Times

    Update

    Well I talked to a tech at Sparkys shop and figured out a few things. Seams ground issues are likely my problem. Apparently the reason the stock antenna is showing such a low swr reading has some thing to do with a resister in the antenna that is "fooling" the swr meter I bought into reading a lower # than what is actually true.

    When I get time I'm going to add ground wires from the mount to the door. I already grounded from the door to the cab. I might run a ground from the cab to the frame also.

    I did buy a bird perch and heavy duty mount and that along with shortening the whip got my readings down to 2.2 on channel 1 and 3 on channel 40. I can't shorten the whip any more with out cutting it. I'm going to wait until I add the ground wires before I do any cutting on the whip unless some one thinks I should just cut it??

    The more I shortened the whip the lower the readings got but the difference from channel 1-40 stayed the same. ie:, I'd shorten the whip 1/4" and the readings would go channel 1: 2.8, channel 40: 3.5... Then I would lower it another 1/4" and the readings would go channel 1: 2.5, channel 40: 3.2 and so on.

  4. #4
    Road Train Member
    Member Since
    Aug 2008
    Location
    Rats nest Grafton North Dakota
    Trucker?
    10 Years
    Age
    47
    Posts
    1,504
    Thanks
    313
    Thanked: 1,389 Times
    Well I am not sure what Volvo you have but the ones I have played with did not have a resistor in the antenna system.

    I am currently running wilson 5000s on my pete. I installed new coax and seperated the system so that the AM/FM does not use the CB antennas. I had to cut more then an inch off the whips to get them tuned correctly.

    Don't be afraid to cut the whip. It is better to cut them to have a properly tuned antenna then to not cut them.

    I have not been a big fan of the K40s because they do have a resistor in them that has been known to go bad.

  5. #5
    Medium Load Member hunts2much's Avatar
    Member Since
    Aug 2008
    Location
    Michigan
    Trucker?
    4 Years
    Posts
    303
    Thanks
    296
    Thanked: 97 Times
    Quote Originally Posted by Rat View Post
    Well I am not sure what Volvo you have but the ones I have played with did not have a resistor in the antenna system.

    Hmm, interesting. I drive an 09 670. Not sure what to think about this one.

    I am currently running wilson 5000s on my pete. I installed new coax and seperated the system so that the AM/FM does not use the CB antennas. I had to cut more then an inch off the whips to get them tuned correctly.

    Don't be afraid to cut the whip. It is better to cut them to have a properly tuned antenna then to not cut them.

    Yeah, as soon as I get home and add the ground straps I will cut the whip if need be.


    I have not been a big fan of the K40s because they do have a resistor in them that has been known to go bad.

    I was all set to buy a Wilson 2000 when I ordered at Sparkys but Al talked me into the K40. I'm so new to this I just went ahead and trusted him (based on his excellent reputation) despite all I have read about the Wilson 2000 being better than the K40. I have read about the resistor in the K40 and again from what I gather the resistor issue is only a problem with a lot of power put to it. Hopefully that is the case.

  6. #6
    Light Load Member Vitointn's Avatar
    Member Since
    Jul 2009
    Location
    Clarksville, TN
    Trucker?
    4 Years
    Age
    54
    Posts
    108
    Thanks
    45
    Thanked: 33 Times
    As was mentioned earlier, ya may wanna make sure that there is good ground for the antenna. I just mounted a Firestick onto the passenger mirror mount because the driver door ground starp was broken and giving me a 3.9:1 reading from the factory mount antenna (06 Intl 9400i).

    Now getting 1.1:1 at the passenger door with an intact ground strap. You can also fabricate a ground wire to go from the antenna mount to a good ground - like my trainer had done for his 08 Intl ProStar...though he was running a Connex 4300HP. I've just got a Cobra 29LTD starter radio.

  7. #7
    Medium Load Member BoDarville01's Avatar
    Member Since
    Apr 2009
    Location
    Atlanta, GA
    Trucker?
    0-1 Year
    Age
    40
    Posts
    299
    Thanks
    11
    Thanked: 58 Times
    Nice quote Mr. Spock., but anyway......

    I'm still having issues with my Galaxy. I'm in the process of trying to figure out just what gives. I bought a used Galaxy from a CB shop off x4 in indianapolis....what a PIECE OF JUNK. i've spent an additional $200 on antennas, coax trying to chase down why my SWRs are so high. Think in the process i've burnt out or am burning out my Galaxy. I just have not had the time to stop at a CB shop to do any work. I really want to stop at the shop off I-70 in Ill. at exit 154. They say they are a high end shop, but all i really want is to just get a working radio. I'm tired of wasting money, and i know going into another CB shop, they'll just end up squeezing as much green out of me as they can seeing how they'd have a driver who dont know jack about CBs, SWRs FMH meters, and whatever else.

    I have a 09 volvo mid roof, and i would like to think the ground with the stock coax is pretty good....but ever since i've last had work done on my radio, i cannot get an SWR below 3:1. and i'm done blowing $100-200 a pop just to get another junk radio/antenna/coax with the same SWR reading.

    CB shops are alot like auto mechanics shops. They see someone in there who they know they can take for a ride, and they get what they want in the end.....more of your money.

  8. #8
    Medium Load Member hunts2much's Avatar
    Member Since
    Aug 2008
    Location
    Michigan
    Trucker?
    4 Years
    Posts
    303
    Thanks
    296
    Thanked: 97 Times
    Well just to update things a little. I managed to get the swr down to 1.5:1 flat across 1-40 by trimming nearly 2" off the whip in 1/4" increments. I've added grounds everywhere I can think of and cant get it any lower than 1.5:1, nor have I seen the readings change one bit from adding all the extra grounds. Think I'm just going to call it good.

  9. #9
    Pie Crust Smaggs's Avatar
    Member Since
    Apr 2011
    Location
    Pittsburgh, PA
    Trucker?
    12 Years
    Posts
    1,397
    Thanks
    301
    Thanked: 672 Times
    I'm having this same problem with my 2010 Volvo 670. Bought a pair of K40 plus antennae. The stock antennae read 1.5:1 and I get a reading of over 3:1 with the K40 plus antennae installed.

    Should I take them back or should I shell out more money and buy new mirror mounts and run new coax? Not sure how to ground, either. The mirror arms are this black powdercoat material.

    Any info would help, since I'm new to antenna mounting.

  10. #10
    Road Train Member EZ Money's Avatar
    Member Since
    Oct 2010
    Location
    Charlotte,NC
    Trucker?
    31 Years
    Posts
    1,872
    Thanks
    993
    Thanked: 909 Times
    Should have bought the Wilson antennas,I have never had a problem getting a good SWR tune on them with good coax and a grounded mount.

    Also that Cobra from Sparky is the one he has with the high output finals right?
    Turn the power down when setting the SWR.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •