Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Results 1 to 5 of 5

Thread: n14 problem

  1. #1
    Bobtail Member
    Member Since
    Sep 2013
    Trucker?
    7 Years
    Posts
    1
    Thanks
    0
    Thanked: 0 Times

    n14 problem

    I have a cummins n14 celect and i have two problems. The first one isn the most important and that is about a week ago the truck has zero throttle. It starts and idles but no throttle at all. Replaced the tps and nothing changed, also that shut down light is on. Does this sound like a toasted computer or no? If so is there a shop in southern california that can possibly test my computer?

    Second question is it takes for ever to start about 10 seconds of starting.......this is the least of my worries right now since i cannot even drive the truck.


  2. #2
    Light Load Member
    Member Since
    Apr 2011
    Trucker?
    10 Years
    Posts
    65
    Thanks
    34
    Thanked: 10 Times
    Did you change the engine position sensor located by the air compressor?
    Do you have a switch you can flip that the check engine light will flash out any fault codes?
    I had that problem with the shutdown light and it was my oil pressure senor to the ecm. However I could give mine throttle.
    As for the starting I had a bad o-ring on a fleetguard filter that was causing mine to take forever to start. Fleetguard filters are very picky on a n-14 for some reason they never want to seal tight. I have been having good luck with Donaldson filters on that engine. If that don't solve your starting problem there is a check valve located on the fuel line where it comes off your ecm heat shield plate. A lot of time this thing builds up with all kinds of crud. Take it off and clean it really good. On the old Celect it will be what looks like a straight fitting on the Celect plus models it will be a 90 degree elbow. Here is a link to a youtube video on that valve. http://www.youtube.com/watch?v=YaFK-_ZbyBI

  3. #3
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Lugansk, UA
    Trucker?
    Trucking Industry
    Posts
    6,379
    Thanks
    24
    Thanked: 1,116 Times
    I sugest bad check valve ore worn fuel delivery pump... so hard to start

    No throutle issue.. Bad wiring

  4. #4
    555
    555 is offline
    Bobtail Member
    Member Since
    Jan 2014
    Trucker?
    5 Years
    Posts
    1
    Thanks
    0
    Thanked: 0 Times

    cummins n4 thumping noise

    Hello fellas I have been flustered and going broke I have been changing parts left right and centre. 2000 International 9400 cummins n14 525 1850. my inframe has 351000 miles. motor gets a thumping noise when its working, my egt climbs to 900 15lbs of boost on the flat. sometimes it almost sounds like a piston is slapping the head. The ECM was changed this month, prior to changing that my exhaust was embarrassingly loud. any help is much appreciated
    Last edited by 555; 01.23.2014 at 12.27 AM. Reason:: bad spelling

  5. #5
    Light Load Member
    Member Since
    Apr 2011
    Trucker?
    10 Years
    Posts
    65
    Thanks
    34
    Thanked: 10 Times
    555 mine does the same thing. I have 120,000 on a inframe. It's been doing it since day one on the rebuild. I have taken it back multiple times and they keep telling me nothing is wrong and make me foot the bill. Now the warranty is up and they have fixed nothing. They suggested it was my air compressor so I replaced it. Then they said I might have a bad cam follower so I replaced them. Then they thought it was a bad roller so they tore it down again and replaced them. Then they sold me a new turbo, exhaust manifold and air to air. Guess what, it still makes the noise. 15 psi boost, 1500rpm or higher just like you stated sounds like a piston is slapping the head! Mine have been doing it over a year now. All oil samples come back normal, mine dyno-ed very excellent, good power, and fuel mileage. 555 did it do this before you replaced the ecm? If you do find the issue PLEASE, PLEASE, PLEASE let me know! I am sick of throwing money into it to correct nothing!