Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Bobtail Member
    Member Since
    Jan 2013
    Trucker?
    Trucking Industry
    Posts
    49
    Thanks
    51
    Thanked: 11 Times

    No Throttle Response 2003 Columbia with Detroit 12.7

    Hey guys, been working on geting this truck on the road again. So far, mechanically, things have seemed ok. I got in the truck this afternoon to move it cause I had to get to the trailer behind it and all of a sudden I have no throttle response (only idle) and a yellow check engine light and ECU 128 showing on the dash. It is a simple setup. FL Columbia with a 12.7 Detroit in it. I'm thinking some kind of a sensor? Any ideas out there?
    Thanks!


  2. #2
    Medium Load Member magoo68's Avatar
    Member Since
    Jun 2011
    Location
    st malo mb canada
    Trucker?
    16 Years
    Posts
    320
    Thanks
    154
    Thanked: 108 Times
    throttle position sensor shot or bad connection would be my guess

  3. The Following User Says Thank You to magoo68 For This Useful Post:


  4. #3
    Bobtail Member
    Member Since
    Jan 2013
    Trucker?
    Trucking Industry
    Posts
    49
    Thanks
    51
    Thanked: 11 Times
    Any idea where this sensor is located? Been fine for a while but sensors go out on the Detroits fairly often. Never had to replace a throttle response sensor.
    Thanks

  5. #4
    Road Train Member baha's Avatar
    Member Since
    Jul 2013
    Location
    ga
    Trucker?
    28 Years
    Posts
    1,075
    Thanks
    758
    Thanked: 375 Times
    no bigge you just unplug an 2 torx head screws, under fuel ped.

  6. The Following User Says Thank You to baha For This Useful Post:


  7. #5
    Medium Load Member magoo68's Avatar
    Member Since
    Jun 2011
    Location
    st malo mb canada
    Trucker?
    16 Years
    Posts
    320
    Thanks
    154
    Thanked: 108 Times
    Quote Originally Posted by baha View Post
    no bigge you just unplug an 2 torx head screws, under fuel ped.
    what he said ^

  8. #6
    Bobtail Member
    Member Since
    Jan 2013
    Trucker?
    Trucking Industry
    Posts
    49
    Thanks
    51
    Thanked: 11 Times
    Ok, thanks for the help there. I'm having some other issues now...We removed the throttle position sensor and tried cleaning the terminals. Went to put sensor back in to see if, possibly, this would help with the throttle response and now we have more codes. First of all, we have the red engine protect light on now, the yellow check engine light is still on, and we get an ecu 128 , PID 091 , Fail 04 , and finally Fault 1. Do any of these ring a bell?

  9. #7
    Road Train Member Freightlinerbob's Avatar
    Member Since
    Jan 2012
    Location
    West Coast B.C.
    Trucker?
    20 Years
    Posts
    1,954
    Thanks
    352
    Thanked: 1,006 Times
    Code 128 is the trailer ABS code isn't it?

  10. #8
    Bobtail Member
    Member Since
    Jan 2013
    Trucker?
    Trucking Industry
    Posts
    49
    Thanks
    51
    Thanked: 11 Times
    Quote Originally Posted by Freightlinerbob View Post
    Code 128 is the trailer ABS code isn't it?
    I think 128 just stands for a general engine code...nothing in particular. I don't think it has anything to do with the trailer.

  11. #9
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Lugansk, UA
    Trucker?
    Trucking Industry
    Posts
    6,394
    Thanks
    24
    Thanked: 1,120 Times
    128 S/P __ F - is like MID128 SID ___ FMI on volvo)) Post full code here

  12. #10
    Medium Load Member magoo68's Avatar
    Member Since
    Jun 2011
    Location
    st malo mb canada
    Trucker?
    16 Years
    Posts
    320
    Thanks
    154
    Thanked: 108 Times
    if u google code it comes up accelerator pedal circuit failed low

Page 1 of 2 12 LastLast