Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Rat
    Rat is offline
    Road Train Member
    Member Since
    Aug 2008
    Location
    Rats nest Grafton North Dakota
    Trucker?
    10 Years
    Age
    46
    Posts
    1,500
    Thanks
    309
    Thanked: 1,367 Times

    Peterbilt fuel tanks GRRRRRR

    I have been running an 04 379 Peterbilt C15 MBN 475. 120 gallon tanks.

    The problem is the thing keeps pumping fuel from one tank and over filling the other. The shop has replaced both splitters and checked the ventlines and fuel lines but they can not find anything that is causing this.


    It was not really a problem before but they just installed a third lift axle on it and had to cut 11 inches off the tanks.

    Before I just did not fill the tanks to the top. I would run around with 3/4 to 1/2 a load of fuel and it did not actually over fill the tank. Now I have alot less capacity and need to fill this thing up. I refuse to fuel in the morning only to have to stop and fuel again in the afternoon.

    I tried to get the company shop to install simple hose from one tank to the other to keep the fuel levels in check but they refuse to do it especially in the winter because they say the line will freeze.

  2. #2
    Road Train Member Peanut Butter's Avatar
    Member Since
    Nov 2007
    Location
    PO Dunk Idaho
    Trucker?
    5 Years
    Age
    52
    Posts
    1,321
    Thanks
    22
    Thanked: 409 Times
    The check valve on the fuel line maybe be bad, i had a kenworth W900L that did that but only when topped out on the speedometer, the truck was set at 70 mph, if i topped out at 70 the fuel went from one tank to the other, but if i kept it at 68 mph it didnt do that, i was told the check valve was at fault for this. anyways thought i would try to help.

  3. #3
    Medium Load Member C16KIWI's Avatar
    Member Since
    Jun 2008
    Location
    New Zealand
    Trucker?
    20 Years
    Age
    44
    Posts
    581
    Thanks
    159
    Thanked: 132 Times
    My T600 used to do this when I took the 3406C out and put the E in I just put a bigger hose in between the tanks.
    With the Western Star it has no cross over hose,the fuel pick up and return splits and feeds both tanks have had no problems,also I think its better at keeping the fuel cooler.

  4. #4
    Road Train Member pullingtrucker's Avatar
    Member Since
    Dec 2008
    Location
    Fostoria, Ohio
    Trucker?
    15 Years
    Age
    35
    Posts
    1,187
    Thanks
    101
    Thanked: 540 Times
    The correct solution would be the crossover hose that the shop won't install. i have never had mine "freeze" either. If you treat the fuel the way you are suppose to and with the hot fuel return that line will never gel. I would check the vents on the left tank. It sounds like that tank may be getting pressurized and causing the fuel to be pushed to the right. Also if you do have the splitter valve that maybe a problem also. They are known for going bad. I would replace the splitter valve with a new one or a Y fitting if the vent is fine.

  5. #5
    Heavy Load Member
    Member Since
    Jan 2008
    Location
    Indiana
    Trucker?
    Trucking Industry
    Posts
    968
    Thanks
    19
    Thanked: 204 Times
    We had this same issue on a 1995 pete 377. We replace the cross over line twice and it did not help. So I crawled under the truck in a parking lot in MO on an old mechanics advice and took a look at the return line. It had a small dip in it very similar to a sink trap under a sink. That sink trap had caused enough pressure to make all of the fuel return to the other tank. I zip tied the line up so that there was not a sink trap in it and I have not had a problem since.

  6. The Following 2 Users Say Thank You to Sportster2000 For This Useful Post:


  7. #6
    Rat
    Rat is offline
    Road Train Member
    Member Since
    Aug 2008
    Location
    Rats nest Grafton North Dakota
    Trucker?
    10 Years
    Age
    46
    Posts
    1,500
    Thanks
    309
    Thanked: 1,367 Times
    Quote Originally Posted by pullingtrucker View Post
    The correct solution would be the crossover hose that the shop won't install. i have never had mine "freeze" either. If you treat the fuel the way you are suppose to and with the hot fuel return that line will never gel. I would check the vents on the left tank. It sounds like that tank may be getting pressurized and causing the fuel to be pushed to the right. Also if you do have the splitter valve that maybe a problem also. They are known for going bad. I would replace the splitter valve with a new one or a Y fitting if the vent is fine.
    Well they replaced the splitter on it about a month ago.

    Today it worked fine but I turned the return line valve on the right tank down to half open and left it there. I am going to run it like that for awhile and see what happens.

    On a positive note. I got 4 mpg today and I bucked some wind and some serious hills. This was grossing 96,850.

  8. #7
    Banned or Retired
    Member Since
    Dec 2008
    Trucker?
    No Answer
    Posts
    2,755
    Thanks
    202
    Thanked: 1,994 Times
    If I remember correctly Pete changed the GT Equalizing valve to a T fitting at about the time your truck was built. For some reason the fuel gets to the T fitting and decides to flow only in one direction...........try replacing the T fitting with a GT equalizing valve. Make sure you have a T fitting in there now, before doing this changer.

  9. #8
    Road Train Member Les2's Avatar
    Member Since
    Jul 2008
    Location
    kicked back in my lazyboy...
    Trucker?
    WannaBe
    Posts
    5,155
    Thanks
    1,772
    Thanked: 2,242 Times
    Quote Originally Posted by Rat View Post
    Well they replaced the splitter on it about a month ago.

    Today it worked fine but I turned the return line valve on the right tank down to half open and left it there. I am going to run it like that for awhile and see what happens.

    On a positive note. I got 4 mpg today and I bucked some wind and some serious hills. This was grossing 96,850.
    Your happy about 4mpg? Dang I'd be PO'd if thats all I got!

  10. #9
    Banned or Retired
    Member Since
    Dec 2008
    Trucker?
    No Answer
    Posts
    2,755
    Thanks
    202
    Thanked: 1,994 Times
    It's a bridge motor.............they get very bad fuel mileage to start with

  11. #10
    Rat
    Rat is offline
    Road Train Member
    Member Since
    Aug 2008
    Location
    Rats nest Grafton North Dakota
    Trucker?
    10 Years
    Age
    46
    Posts
    1,500
    Thanks
    309
    Thanked: 1,367 Times
    Quote Originally Posted by Les2 View Post
    Your happy about 4mpg? Dang I'd be PO'd if thats all I got!
    Considering that the best it has ever gotten was about 3.5 then I am happy.

Page 1 of 2 12 LastLast