2000,ISX Signature 600

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Gonzo_, Jun 6, 2010.

  1. Gonzo_

    Gonzo_ Medium Load Member

    Messages:
    307
    Thanks Received:
    129
    Joined:
    Oct 30, 2008
    Location:
    Clayton, NC
    I have a 2001 Pete that has a 2000 model ISX in it.. It's a early Signature and hasen't had anything done to it! The Cummins shops are amazed it's never had the heads off & it has the old style flat top pistons and old liners :biggrin_25524:
    I've had this truck since it had 300k on it I now have 800k on it. It just got outa the shop for the overhead. I run the overhead every year.. It runs 50% better this time since doing it this time.. Pulls like a bear again :biggrin_255:
    Now I had a jake problem before the valve adjustment, it kinda studdered like it wasn't in high but in med. setting.. After the valve adj. it worked fine for 1 week or so, now it's working terrible again..
    I went back to Cummins.. they test drove it, but couldn't get a good view of the problem.. I was bobtailing. It is only noticable when loaded heavy. (It works fine at low RPM..but as RPM climbes it starts stuttering again.. Cummins says it must be the springs in the jake getting weak and only a overhaul will guarentee fixing the problem.

    With everything else running good, I can't see tearing down a motor & spending $14-$18k on rebuilding it :biggrin_2555:
    Oh a few hiccups have appeared but nothing serious so far.. Still runs great! (Has had a lot of blowby and used oil a LOT since I've owned it.. I was concerned but Cummins assured me it was okay.. about 1 gal. every 3000 mi. sometimes more with lotsa idleing)

    Any suggestions? Bite bullet and rebuild?? Get second opinion?? Rebuild just Jake??
     
  2. sandman1976

    sandman1976 Medium Load Member

    Messages:
    388
    Thanks Received:
    41
    Joined:
    Mar 5, 2009
    Location:
    burgaw,nc
    the jakes are what they want to rebuild,not the engine
     
  3. Rnz520

    Rnz520 Bobtail Member

    Messages:
    30
    Thanks Received:
    7
    Joined:
    May 4, 2010
    Location:
    Fredericksburg, VA, USA
    Yea really they should just have to do the jakes, unless its an oil pressure problem affecting the jakes but a jake rebuild or replacement should fix most cases of a weak jake. Then again the Interbrake on the ISX is unique.
     
  4. rollinsmoke

    rollinsmoke Light Load Member

    Messages:
    61
    Thanks Received:
    8
    Joined:
    Dec 23, 2008
    The jake actuation piston will stick at times and cause that to happen. Had it happen on my truck and the whole truck would shake when i hit the jakes. Replaced them and ran the overhead worked like new agian. Easy and cheap fix 2. Hope that helps
     
  5. T800H

    T800H Medium Load Member

    Messages:
    374
    Thanks Received:
    119
    Joined:
    Apr 2, 2010
    Location:
    The Keys
    I don't know much about the Signature or newer ISX motors but is everybody here aware that this motor does not come with an ad on jake? the jake on these motors is part of the motor, the only reason why they have twin cams is because one cam runs the jake, if you guys know this then excuse my intrusion on this thread.
     
  6. Floyd

    Floyd Light Load Member

    Messages:
    163
    Thanks Received:
    22
    Joined:
    Jun 1, 2010
    Location:
    Central Maine
    Good point. I think Cummins called it an interbrake.? But I think 1 cam runs the injectors, and 1 cam runs both the intake and exhaust valves.
     
  7. Gonzo_

    Gonzo_ Medium Load Member

    Messages:
    307
    Thanks Received:
    129
    Joined:
    Oct 30, 2008
    Location:
    Clayton, NC
    I called Cummins (different shop) and yes, they do make a rebuild kit for my Jake. The kit runs from $280 -$300 (depending on which parts counter u talk to).
    A ballpark labor rate of 6 hrs. To do the job. There's a couple more concerns I have.
    The kit does not come with a solenoid. Is it a good idea to put one in while your in there anyways?

    To address the other remarks to my thread, yes it has 2 cams. One cam is for the Jake the other is for everything else.. Like a normal truck. There is no add-on Jake w/ the ISX.. It is built into the motor. (it's the best working Jake out there!!)

    I'm glad I asked about rebuilding the Jake in here. I guess the Cummins shop that I went to didn't want to help me but rather help themselves & push for a complete inframe! Wait till I complain to their corporate HQ about this!
    Thanks 4 the insite to my little delema.
     
  8. Gonzo_

    Gonzo_ Medium Load Member

    Messages:
    307
    Thanks Received:
    129
    Joined:
    Oct 30, 2008
    Location:
    Clayton, NC
    Oh, by the way.. Just to further describe my problem.. My truck doesn't shake at all. It just acts like the Jake is in stage 2 all the time. The only time it goes into 3 is when I'm at LOW rpm's.. Then it engages normal, pick up speed.. back to the studder like it's in stage 2.. it won't go into 3 at all anymore when u realy need it to. (like a long hill..)
     
  9. Gonzo_

    Gonzo_ Medium Load Member

    Messages:
    307
    Thanks Received:
    129
    Joined:
    Oct 30, 2008
    Location:
    Clayton, NC
    Gonna get a rebuild done on the Jake June 23... Will let you know if problem is solved or not. Oh, the kit doesn't come with the slave pistons so I am going to throw a new set of them in to while I'm in there.. (They're like $65 each & I'm gonna need 6 of them)..

    Hope this works!
     
  10. cumminspwr600

    cumminspwr600 Light Load Member

    Messages:
    62
    Thanks Received:
    6
    Joined:
    Dec 16, 2008
    Location:
    pittsburgh,pa
    with the valve cover you may want to run engine and check for air bubbles comming in between rocker levers it sounds kinda like what you are describing and most owners don't notice any loss of oil pressure if you see air the truck most likely needs a new oil pump