N14 CelectPlus Engine Wiring Harness 3411481

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Smellfunny, Dec 15, 2012.

  1. Smellfunny

    Smellfunny Medium Load Member

    Messages:
    522
    Thanks Received:
    147
    Joined:
    Jan 28, 2012
    Location:
    South Carolina
    Have a n-14 wire harness to install on a truck and the new harness (3411481) has a fuse with a wire connector right at the connector for the C plug. I tested it out and it appears to be a ground. Is this correct and does it attach to one of the ECM mounting bolts or is there somewhere else that I should ground it to?
     
  2. Heavyd

    Heavyd Road Train Member

    Messages:
    3,894
    Thanks Received:
    1,597
    Joined:
    Feb 4, 2009
    Yes correct. It does attach to one of the ecm bolts. It is to protect the ecm from other components using the ecm as a ground, like when the main ground cables start to get bad. 10 amp fuse I think.
     
  3. Smellfunny

    Smellfunny Medium Load Member

    Messages:
    522
    Thanks Received:
    147
    Joined:
    Jan 28, 2012
    Location:
    South Carolina
    I was about to PM you Heavyd. : ) Thanks.

    This is the first harness I have replaced that is like this one and I was 99% sure that is how it was but wanted to make it 100%. I have a bad feeling these guys that own the truck have burned out the ECM that they put on before they brought the truck to me. I tested the harness (the old one) after they towed it to me and it was bad so I am installing a new one. They said there was no fire to the fuel solenoid and they had ran a hot wire to it before they brought it to me.

    I installed a new solenoid and the harness is on and connected (other than the battery cables/connections) for testing Monday morning. I wanted to have a fresh start Monday instead of a rush to finish Friday.
     
  4. Heavyd

    Heavyd Road Train Member

    Messages:
    3,894
    Thanks Received:
    1,597
    Joined:
    Feb 4, 2009
    Those ECMs are pretty tough! It takes a lot to fry them.
     
  5. Smellfunny

    Smellfunny Medium Load Member

    Messages:
    522
    Thanks Received:
    147
    Joined:
    Jan 28, 2012
    Location:
    South Carolina
    Well no power to fuel solenoid. I unhooked everything and rechecked power and grounds and everything tested good. The owner is Supposed to be checking with salvage yard he got ECM from about another one. I don't have a Celect plus test box at the moment.
     
Draft saved Draft deleted