N14 water pump

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Mr. Truck Fixer, Oct 25, 2012.

  1. Mr. Truck Fixer

    Mr. Truck Fixer Bobtail Member

    Messages:
    44
    Thanks Received:
    12
    Joined:
    Jan 27, 2012
    Location:
    Ontario
    Wondering if anyone has ever had repeat water pump failure on n14. The original one lasted 7 years now I changed three in six months. What gives? Another truck in the fleet has had 6 pumps is twelve years. Getting tired of changing water pumps. Dca levels are always good and good quality coolant.
     
  2. losttrucker

    losttrucker Road Train Member

    Messages:
    1,438
    Thanks Received:
    1,000
    Joined:
    Mar 9, 2008
    Location:
    greenville,nc

    In my opinon its the supplier using cheap rebuild kits as I had the same problem with my Detroit!! Example, the backing plate on the original was metal while on the rebuilt ones (all 3) have had cheap flimsy plastic that seem to start leaking immediately!!
     
  3. Mr. Truck Fixer

    Mr. Truck Fixer Bobtail Member

    Messages:
    44
    Thanks Received:
    12
    Joined:
    Jan 27, 2012
    Location:
    Ontario
    Always replaced with reman cummins parts. Flushed and new rad cap everytime.
     
  4. Smellfunny

    Smellfunny Medium Load Member

    Messages:
    522
    Thanks Received:
    147
    Joined:
    Jan 28, 2012
    Location:
    South Carolina
    We had an N-14 that we put 2 on back to back. They were aftermarket (Haldex).
     
  5. blanco

    blanco Road Train Member

    Messages:
    1,218
    Thanks Received:
    268
    Joined:
    Nov 20, 2009
    Location:
    Gwinnett County, GA
    I'm ready to do mine sometime soon. I've had replaced it 5 yrs ago. Cummins reman. It is the only one I will use.
     
  6. JohnP3

    JohnP3 Road Train Member

    Messages:
    1,594
    Thanks Received:
    618
    Joined:
    Feb 21, 2010
    Location:
    Rock Creek B.C. Canada
    Haldex is a Cummins division, and if you are using DCA4 that does not help at all it is 100% crap, if you do not change the filter it will wear out the seal easily, the belt it needs to be adjusted properly. I always used OEM reman, and never use DCA4, The rust you see when you have the pump off is nothing compared to the damage to the liners.
     
Draft saved Draft deleted