No Throttle Response 2003 Columbia with Detroit 12.7

Discussion in 'Freightliner Forum' started by 68Goat, Dec 1, 2013.

  1. 68Goat

    68Goat Light Load Member

    Messages:
    53
    Thanks Received:
    12
    Joined:
    Jan 4, 2013
    Hey guys, been working on geting this truck on the road again. So far, mechanically, things have seemed ok. I got in the truck this afternoon to move it cause I had to get to the trailer behind it and all of a sudden I have no throttle response (only idle) and a yellow check engine light and ECU 128 showing on the dash. It is a simple setup. FL Columbia with a 12.7 Detroit in it. I'm thinking some kind of a sensor? Any ideas out there?
    Thanks!
     
  2. magoo68

    magoo68 Heavy Load Member

    Messages:
    930
    Thanks Received:
    476
    Joined:
    Jun 11, 2011
    Location:
    st malo mb canada
    throttle position sensor shot or bad connection would be my guess
     
    68Goat Thanks this.
  3. 68Goat

    68Goat Light Load Member

    Messages:
    53
    Thanks Received:
    12
    Joined:
    Jan 4, 2013
    Any idea where this sensor is located? Been fine for a while but sensors go out on the Detroits fairly often. Never had to replace a throttle response sensor.
    Thanks
     
  4. baha

    baha Road Train Member

    Messages:
    1,731
    Thanks Received:
    592
    Joined:
    Jul 25, 2013
    Location:
    ga
    no bigge you just unplug an 2 torx head screws, under fuel ped.
     
    68Goat Thanks this.
  5. magoo68

    magoo68 Heavy Load Member

    Messages:
    930
    Thanks Received:
    476
    Joined:
    Jun 11, 2011
    Location:
    st malo mb canada
    what he said ^
     
  6. 68Goat

    68Goat Light Load Member

    Messages:
    53
    Thanks Received:
    12
    Joined:
    Jan 4, 2013
    Ok, thanks for the help there. I'm having some other issues now...We removed the throttle position sensor and tried cleaning the terminals. Went to put sensor back in to see if, possibly, this would help with the throttle response and now we have more codes. First of all, we have the red engine protect light on now, the yellow check engine light is still on, and we get an ecu 128 , PID 091 , Fail 04 , and finally Fault 1. Do any of these ring a bell?
     
  7. Freightlinerbob

    Freightlinerbob Road Train Member

    Messages:
    2,235
    Thanks Received:
    1,263
    Joined:
    Jan 15, 2012
    Location:
    West Coast B.C.
    Code 128 is the trailer ABS code isn't it?
     
  8. 68Goat

    68Goat Light Load Member

    Messages:
    53
    Thanks Received:
    12
    Joined:
    Jan 4, 2013
    I think 128 just stands for a general engine code...nothing in particular. I don't think it has anything to do with the trailer.
     
  9. Pablo-UA

    Pablo-UA Road Train Member

    Messages:
    7,132
    Thanks Received:
    1,308
    Joined:
    Oct 11, 2010
    Location:
    Borispol, Ukraine
    128 S/P __ F - is like MID128 SID ___ FMI on volvo)) Post full code here
     
  10. magoo68

    magoo68 Heavy Load Member

    Messages:
    930
    Thanks Received:
    476
    Joined:
    Jun 11, 2011
    Location:
    st malo mb canada
    if u google code it comes up accelerator pedal circuit failed low
     
Draft saved Draft deleted