Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Bobtail Member
    Member Since
    Feb 2011
    Location
    Roseville, ca
    Trucker?
    3 Years
    Posts
    30
    Thanks
    2
    Thanked: 3 Times

    fault codes 2006 cummins 435 isx

    I have 2 fault codes one is PID 131_A and one is PID 131_P
    I went to cummins site and they only give code 131 which is the accelorator level sensor which I gather is the 131_A code which shoed up about 3 weeks ago. Last night when my tail lights stayed on with key and lights off nd my brake lights did not work the 131_P code showd up. I drove about 50 miles and everything went back to normal. Anyone have an idea what the P code might be and why tail lights staye on while brake lights did not work ?


  2. #2
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,588
    Thanks
    24
    Thanked: 1,152 Times
    P- passive code - it is not actual code, it is stored in EPRO and may be erased, A - current fault.

    Well, check pin #2 voltage on foot throutle sensor, about 0.5V - idle, 4.6V - kick down.

    Connect DVOM to #1 and # 2 termilals (#3 - is 5V supply) and slowly press pedal and look at DVOM reading. If you see erratic data - change gas pedal, if everething is OK - check wiring

  3. #3
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,588
    Thanks
    24
    Thanked: 1,152 Times
    Quote Originally Posted by DHF View Post
    I have 2 fault codes one is PID 131_A and one is PID 131_P
    I went to cummins site and they only give code 131 which is the accelorator level sensor which I gather is the 131_A code which shoed up about 3 weeks ago. Last night when my tail lights stayed on with key and lights off nd my brake lights did not work the 131_P code showd up. I drove about 50 miles and everything went back to normal. Anyone have an idea what the P code might be and why tail lights staye on while brake lights did not work ?
    One quation: did you get fault code 131 ore fault code MID 128 PID 131, if MID 128 PID 131 it is not gas pedal, it is exaust pressure. What is FMI? you may get bad EGR, bad turbine actuator ore clogged muffler.

    Can I see code in full format MID 128 PID 131 FMI ?? what is FMI?

  4. #4
    Light Load Member pichu's Avatar
    Member Since
    Jan 2009
    Location
    mexifornia
    Trucker?
    25 Years
    Age
    49
    Posts
    103
    Thanks
    43
    Thanked: 16 Times
    Quote Originally Posted by Pablo-UA View Post
    One quation: did you get fault code 131 ore fault code MID 128 PID 131, if MID 128 PID 131 it is not gas pedal, it is exaust pressure. What is FMI? you may get bad EGR, bad turbine actuator ore clogged muffler.

    Can I see code in full format MID 128 PID 131 FMI ?? what is FMI?
    yes pablo!PID 131 Engine Exhaust Gas Pressure , FMI 2 - 2 Data erratic, intermittent, or incorrect ! may be the muffler is plugged (to much back pression)

  5. #5
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,588
    Thanks
    24
    Thanked: 1,152 Times
    ore EGR, turbine and actuator are full of ash and soot, and may be EGR will fail soon....

  6. #6
    Bobtail Member
    Member Since
    Feb 2011
    Location
    Roseville, ca
    Trucker?
    3 Years
    Posts
    30
    Thanks
    2
    Thanked: 3 Times
    Thanks for the response guys .... Above the PID 131_A and PID_P there is another set of letters and numbers I was told was not part of code but the last digit does change from 2 to 4 when the 2nd P code is displayed. If my memory serves me correctly the # above 128.F02 and 128.F04 when I press and hold button to display 2nd fault code. I it happens to be wiring leading to accelorator sensor and not sensor, are the wires for sensor near wires for tail lights possibly and or work lights as I have had issues with both those lights coming on by themselves with key off and there isn't even a switch for the work lights.... The tail lights have corrected themselves for time being but had to pull fuse for work lights to get them to stay off. Thinking all 3 problems might be a short between wires if these wires are all near each other. Going to order a factory manual to get wiring diagram .... Have a retired air plane mechanic who specialized in electrical who is going to help trouble shoot. A couple weeks ago I did buy another pedal from wrecker as backup in case sensor went out and installed it but had an issue with truck not going more than 15 mph after about 2 weeks a couple times which went away after a short period but I switched back to old pedal and so far no issue like that. I have heard internationals are touchy when it comes to electrical .... Hope the air plane guy will figure it out....I will pass your input along to him as it could help him out being this is his 1st big rig electrical task.

  7. #7
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,588
    Thanks
    24
    Thanked: 1,152 Times
    PID 131 is not sensor, it is back pressure issue.

    PID 131 Engine Exhaust Gas Pressure, FMI 2 - 2 Data erratic, intermittent, or incorrect

    The nexy step - hook laptop up with cummins Insite Software and do actual values monitoring....

    Man, it is turbo actuator ore clogged muffler.

  8. #8
    Road Train Member Heavyd's Avatar
    Member Since
    Feb 2009
    Trucker?
    Trucking Industry
    Age
    39
    Posts
    3,456
    Thanks
    563
    Thanked: 1,297 Times
    The exhaust pressure sensor fails about as often as an EGR valve. If you get this code a really good chance it is just the sensor.

  9. #9
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,588
    Thanks
    24
    Thanked: 1,152 Times
    Quote Originally Posted by Heavyd View Post
    The exhaust pressure sensor fails about as often as an EGR valve. If you get this code a really good chance it is just the sensor.
    When sensors fails we can get "electrical fault" code, but FMI2 - data irratic ore incorrect. So the next step - hook up laptop and trace fault code according workshop manual. Anyway I agree DO THE CHEAP STUFF FIRST works

  10. #10
    Road Train Member Heavyd's Avatar
    Member Since
    Feb 2009
    Trucker?
    Trucking Industry
    Age
    39
    Posts
    3,456
    Thanks
    563
    Thanked: 1,297 Times
    Straight from the ISX troubleshooting, if you have an active exhaust pressure sensor code for "data irratic, incorrect" at key on, engine off, and don't have active code 689 or 778 - step 2 is replace the sensor!
    I am not sure of the PID codes. Cummins lists the Exhaust pressure sensor as PID P95. Cummins code for Exhaust pressure sensor data invalid, incorrect is 2554. You will get this code as the sensor starts to "die". After it burns out you will get 2374 for signal shorted low and/or 2373 shorted high. Either way, trouble shooting has always found a failed sensor, not a plugged exhaust or failed turbo or whatever!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •