Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Results 1 to 7 of 7
  1. #1
    Heavy Load Member
    Member Since
    Jan 2011
    Location
    Irvine, AB
    Trucker?
    14 Years
    Posts
    878
    Thanks
    102
    Thanked: 230 Times

    Cruise control quit - 98 FLD120

    It was workin fine yesterday n last night I changed out my dash lights for LEDs n then it hasnt worked since. It wont work for high idle either. Any ideas?


  2. #2
    Medium Load Member
    Member Since
    Apr 2012
    Location
    Cleburne, Tx
    Trucker?
    0-1 Year
    Posts
    593
    Thanks
    49
    Thanked: 249 Times
    Always check the last thing you messed with first.
    Make sure you have polarity correct and no accidental grounds...
    Also... did you check to see if you need a ballast module with the led's?
    Some do or not, depends on your lighting system/wiring...
    Mary

  3. The Following User Says Thank You to Krashdragon For This Useful Post:


  4. #3
    Forum Leader/Admin bullhaulerswife's Avatar
    Member Since
    Jul 2007
    Location
    Midwest
    Trucker?
    Trucker's Significant Other
    Posts
    19,818
    Thanks
    30,711
    Thanked: 20,344 Times
    My Truckers Blog
    2
    Quote Originally Posted by CbarM View Post
    It was workin fine yesterday n last night I changed out my dash lights for LEDs n then it hasnt worked since. It wont work for high idle either. Any ideas?
    You have the answer right there. Hubby had issues too and there was a wiring issue with the harness, and the issue was clear up by the headlights. Somehow by changing out the lights, you've eliminated a circuit to the cruise.

  5. #4
    Trucker Forum STAFF PackRatTDI's Avatar
    Member Since
    Jul 2006
    Location
    El Chuco, Tejas
    Trucker?
    5 Years
    Age
    39
    Posts
    7,562
    Thanks
    220
    Thanked: 6,965 Times
    The Freightliner I drove for my old employer had too many electrical gremlins to count.

  6. #5
    Light Load Member deskdriver's Avatar
    Member Since
    Aug 2013
    Location
    Michigan
    Trucker?
    Trucking Industry
    Posts
    240
    Thanks
    44
    Thanked: 134 Times
    If it is not related to the light you just changed another common problem on the fld 120's is the saftey switch on the clutch, it could either be bad or your clutchn is so far out of adjusment that it is not all the way at the top. While driving lift up on the clutch pedal with your left foot and see if the cruise works.

  7. #6
    Heavy Load Member
    Member Since
    Jan 2011
    Location
    Irvine, AB
    Trucker?
    14 Years
    Posts
    878
    Thanks
    102
    Thanked: 230 Times
    I actually did test out the clutch switch n my jake is workin normal. I replaced my dash lights with identical lights but went to red from blue so I wouldnt think that would cause any problems...

  8. #7
    Heavy Load Member
    Member Since
    Jan 2011
    Location
    Irvine, AB
    Trucker?
    14 Years
    Posts
    878
    Thanks
    102
    Thanked: 230 Times
    I have switched my lights back to the original ones and nothing still. Not sure what else to check. Is there a fuse somewhere for the cruise?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •