Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Medium Load Member Elroythekid's Avatar
    Member Since
    Sep 2010
    Location
    Halifax nova scotia
    Trucker?
    15 Years
    Posts
    659
    Thanks
    402
    Thanked: 241 Times

    DD15 Regen help!!

    My 2011 EPA 07 DD15 runs ok until it regens, then it loses all boost unless you are on a hill and pounding it, during steady flat ground cruising you can hear the throttle valve slam shut and then the boost dies. If you pull into stop and go traffic or city speeds it really doesnt run well below 1400, bucking and farting, huge hesitation, lots of rattling then at 1400 wakes up and builds boost and takes off, when you shift you can hear the throttle valve once again slam shut and it does the same thing. Detroit Diesel mechanics had it for 3 days on the dyno replace turbo actuator and throttle valve, nothn, it still does it. I have had 2 of them out for a drive with the lap top, they put it in regen mode and take a log file of it. They both agree that it should not work that way but when they send the log file to Detroit engineers they say engine is running within spec no fault found. The service mgr told them it works bad and they said I will have to live with it. My salesman tells me he has asked other o/o's and they say their trucks do the same thing? Does anybody have the same experience? I have asked several Cascadia drivers and they all say they cant tell a regen is happening unless the light comes on. ALL COMMENTS GREATLY APPRECIATED ON THIS SUBJECT!! I need some ammo to go back to my dealer with! I'm ready to contact a lawyer as this truck is being a nightmare!!
    Thanks!!

  2. #2
    Light Load Member SLCTrucker's Avatar
    Member Since
    Jan 2009
    Location
    Salt Lake City UT
    Trucker?
    20 Years
    Age
    47
    Posts
    281
    Thanks
    96
    Thanked: 123 Times
    I have the same problems as you... Mine is a 2009 DD15
    Did the dyno, roadtest in regen mode also.
    No faults found either....
    Have not replaced any parts yet...
    I got 670,000 on mine, it started about 550,000
    Am still looking, keep me updated if you find anything, I will do the same..

  3. #3
    Light Load Member SLCTrucker's Avatar
    Member Since
    Jan 2009
    Location
    Salt Lake City UT
    Trucker?
    20 Years
    Age
    47
    Posts
    281
    Thanks
    96
    Thanked: 123 Times
    Well DD15 started to have regen issues, just got it fixed tonight, got to the point it would not regen moving, then would not even do a parked regen....

    They believe this issue was causing it to run rough under regen & from what they looked at, files they sent to detroit it all seems to make sense.

    Got it out of shop tonight, will not start running till tomorrow so untill it does a rolling regen I wont know if it fixed it or not......

  4. #4
    Medium Load Member Elroythekid's Avatar
    Member Since
    Sep 2010
    Location
    Halifax nova scotia
    Trucker?
    15 Years
    Posts
    659
    Thanks
    402
    Thanked: 241 Times
    Had my truck into Detroit diesel yesterday to get a new ECM. It also needed a new clutch switch. I have only put 500 kms on it so far but it seems to be cured. The jalke and cruise are working and it is not limiting at 95 any more it runs right up to 105km hour no prob. It was doing a regen every 500kms and running real bad but since the ECM first 500 kms and if it did a regen it wasn't an issue and I didn't notice it at all... I need to find some wood to knock on.... I will update ina couple days when I have some more miles on it.

  5. #5
    Light Load Member SLCTrucker's Avatar
    Member Since
    Jan 2009
    Location
    Salt Lake City UT
    Trucker?
    20 Years
    Age
    47
    Posts
    281
    Thanks
    96
    Thanked: 123 Times
    Well have done 1000 miles since they my truck stopped doing a regen, they seem to of fixed it.

    Got to Freightliner at Lincoln NE, the truck would no longer regen.
    They tried to force a regen failed x2 due to low temp.
    I already had dozer valve & dozer injector changed in Gary IN thinking maybe it would fix it, but it just got worse.
    After the 2 fails they got detroit involved, sent a log file to detroit because they could not work out why it would not regen, It all seemed to work ok.

    The findings, The dozer was putting the fuel into the system correctly, but the pipe from the dozer to dpf was BLOCKED & also causing backpressure so the fuel was not getting to the dpf hence failed regens because of lack of heat.

    They cleaned out the pipe that was blocked & it regens ok now.
    I have run maybe 1000 miles since it was done, can I tell it regens, yes, but only because I know this truck really well, if I did not have the turbo boost gauge I dont think I would know. It still drops to zero during regens, but I have been told more than once this is normal & they were telling me I was just thinking the turbo boost was bad because of me seeing it drop like that..
    I have dropped the RPMs as low as 1000 & stepped on it & the truck goes, no hesitation at all.
    Pulled into the scale in UT & it was doing a regen then run fine & acclerated away fine too...

  6. The Following User Says Thank You to SLCTrucker For This Useful Post:


  7. #6
    Medium Load Member Elroythekid's Avatar
    Member Since
    Sep 2010
    Location
    Halifax nova scotia
    Trucker?
    15 Years
    Posts
    659
    Thanks
    402
    Thanked: 241 Times
    Thanks!! Ill tak to the guys at Detroit diesel about this and see what they think.

  8. #7
    Bobtail Member
    Member Since
    Oct 2012
    Trucker?
    25 Years
    Posts
    9
    Thanks
    0
    Thanked 2 Times in 1 Post
    Hello, my name is Chris. I own a 2008 freight liner XL with a Detroit 60 series engine. It's been a nightmare since I've owned it. New injectors, a new head, new computer, 3 dpf,s , no power. After 2 years, they replaced the engine, only 85000kms on it, i do alot of local work. They could not tell me why all the problems. Now the new engine doing the same thing, no power , blowing black smoke, they replaced injectors and dpf after 75000kms. I've had enough of this down time and lost money for there reserch. I'm waiting for a Canadian Detroit rep for some answers and want my truck replaced with one that works. Still no call back after 3 weeks. Please write me back to let me know if you received this . Thanks. Chris.

  9. #8
    Road Train Member Freightlinerbob's Avatar
    Member Since
    Jan 2012
    Location
    West Coast B.C.
    Trucker?
    20 Years
    Posts
    1,647
    Thanks
    301
    Thanked: 758 Times
    A diesel with a throttle valve? Whatever you're hearing, it's not a throttle valve.

  10. #9
    Road Train Member Heavyd's Avatar
    Member Since
    Feb 2009
    Trucker?
    Trucking Industry
    Age
    38
    Posts
    3,127
    Thanks
    473
    Thanked: 1,081 Times
    Maxxforce line of engine have throttle valves. Specifically they are called engine throttle valves. It is a valve in the intake to choke off intake air to increase exhaust heat to aid in a regen and cold weather operation to warm the engine faster.

  11. #10
    Medium Load Member Elroythekid's Avatar
    Member Since
    Sep 2010
    Location
    Halifax nova scotia
    Trucker?
    15 Years
    Posts
    659
    Thanks
    402
    Thanked: 241 Times
    I got rid of mine. ALL 2008 trucks regardless of manufacturer have those problems. Go to diesel spec in Montreal and have it all removed. Apparently the 60 series is easy to do and you will get much better mpgs and no regen crap.

Page 1 of 2 12 LastLast