Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 6 of 7 FirstFirst ... 4567 LastLast
Results 51 to 60 of 69
  1. #51
    Medium Load Member HwyPilot's Avatar
    Member Since
    May 2008
    Location
    Northern Georgia
    Trucker?
    5 Years
    Age
    43
    Posts
    452
    Thanks
    823
    Thanked: 390 Times
    So far I've always been pleased with the power my 05 ISX puts down (and the jakes are AWESOME) - my main complaint has been trying to break the 6mpg barrier. IMO someone should start a class action lawsuit on the crappy EGR systems, and the lack of retrofitting for their disaster of a design. While mine was in the shop getting a new cooler and EGR valve, I had the overhead done and up-rated to 550HP (from 475). I haven't noticed much difference outside of other changes I had made (LBSC off, GDP off).

    $2000 would be more reasonable, but I still think it should be our option to have this junk removed from our trucks and thrown over the fence. Thanks to the ya-hoos in the state capitals, most states have idle penalties on anything pre-2007 - GREAT - so my 05 EGR equipment gets me nothing but less mpg and more expense. Not to mention the risk of blowing up a $20,000 engine because of a poorly designed EGR cooler that has been shown to fail more often than not. THANKS EPA!! I'll breathe so much better knowing it may cost me the food on my plate.

  2. #52
    Light Load Member
    Member Since
    May 2011
    Location
    chicago,il
    Trucker?
    7 Years
    Posts
    90
    Thanks
    22
    Thanked: 11 Times
    i'm driving a volvo 06 with isx475 , all i did is egr plug disconnected, little welding performance ,met illinois diesel doctor to get this thing to be full open ...that's it!!!! power great ,pulling great couldn't be better

  3. #53
    Bobtail Member
    Member Since
    Jun 2011
    Trucker?
    36 Years
    Posts
    2
    Thanks
    1
    Thanked: 0 Times
    2006 International 9900I, ISX 475, 13 speed overdrive, 3:73 rears on small rubber
    Problem: Intermitent when engine at operating temp. low power, occasional EGR bark, high water temp (210 F), fan comes on at 190 F for 2 seconds, 200 F for 1 or 2 seconds and 210 F for almost 25 seconds. continuous black smoke while pulling under load in top 2 gears, fuel milage at high 4s to low 5 mpg

    When parked running A/C at operating temp, flashing warning lights(high water temp, low oil pressure etc), beeping consistant, ALL gauges pinning themselves to max limits including (voltage, oil pressure,water temp, tach and speedo)

    Replaced 2 EGR valves, exhaust temp sensor ,removed and cleaned exhaust pressure tubes along with the air intake horn, removed as many electrical plugs as I could get at , cleaned with electronic contact cleaner and applied dielectric grease.

    Conclution; Can't decide if I should throw more money into it having certified technicians guess at the problem or just yank it out and drop in a N-14 and use my ISX for a good boat anchor.

    What do you all think ?

  4. #54
    Bobtail Member
    Member Since
    Apr 2011
    Trucker?
    No
    Posts
    5
    Thanks
    0
    Thanked: 0 Times
    pull the air actuator off of the turbo and see if the sector shaft moves freely up and down. if it feels like it has tension on it or is stuck you need a new turbo. common problem with black smoke under a pull. as far as the other weird things...if you have a test ecm available i would try that and see what happens.

    Quote Originally Posted by rbelinger View Post
    2006 International 9900I, ISX 475, 13 speed overdrive, 3:73 rears on small rubber
    Problem: Intermitent when engine at operating temp. low power, occasional EGR bark, high water temp (210 F), fan comes on at 190 F for 2 seconds, 200 F for 1 or 2 seconds and 210 F for almost 25 seconds. continuous black smoke while pulling under load in top 2 gears, fuel milage at high 4s to low 5 mpg

    When parked running A/C at operating temp, flashing warning lights(high water temp, low oil pressure etc), beeping consistant, ALL gauges pinning themselves to max limits including (voltage, oil pressure,water temp, tach and speedo)

    Replaced 2 EGR valves, exhaust temp sensor ,removed and cleaned exhaust pressure tubes along with the air intake horn, removed as many electrical plugs as I could get at , cleaned with electronic contact cleaner and applied dielectric grease.

    Conclution; Can't decide if I should throw more money into it having certified technicians guess at the problem or just yank it out and drop in a N-14 and use my ISX for a good boat anchor.

    What do you all think ?

  5. #55
    Light Load Member bdmose's Avatar
    Member Since
    Aug 2008
    Location
    anywhere but my home in VA
    Trucker?
    3 Years
    Posts
    143
    Thanks
    76
    Thanked: 31 Times
    I don't know who to blame, the mechanics at KW/Cummins or the ISX. My truck is in the shop getting its 5th turbo...........Obviously something else is wrong and the "code readers"/"mechanics" are just replacing 1 after another without finding the true problem. I have an 07 t2000, I believe this was the first year they put the Regen system on. Has anyone else had that many problems with ANY truck they have ever driven?

  6. #56
    Light Load Member
    Member Since
    Dec 2010
    Location
    Springfield, OH
    Trucker?
    9 Years
    Posts
    106
    Thanks
    24
    Thanked: 19 Times
    Do you let the turbo cool down before shutting it off?

  7. #57
    Bobtail Member
    Member Since
    Nov 2011
    Trucker?
    16 Years
    Posts
    4
    Thanks
    0
    Thanked: 0 Times
    This truck should pull with that motor and those gears.. The turbos in this motor stick and it sounds like that is what it doing to you! Ask cummins for policy on it ! They should help you out ! Good luck!

  8. #58
    Bobtail Member
    Member Since
    Oct 2011
    Location
    Southeast
    Trucker?
    15 Years
    Posts
    47
    Thanks
    2
    Thanked: 11 Times
    Quote Originally Posted by bdmose View Post
    I don't know who to blame, the mechanics at KW/Cummins or the ISX. My truck is in the shop getting its 5th turbo...........Obviously something else is wrong and the "code readers"/"mechanics" are just replacing 1 after another without finding the true problem. I have an 07 t2000, I believe this was the first year they put the Regen system on. Has anyone else had that many problems with ANY truck they have ever driven?
    Well, I'm sorry to say this, but you have about the worst truck spec wise for having major issues. The early T2000's were nightmares with the new regen, and it's the same way with the ISX. I sold many of these trucks before the problems slowly started overwhelming Paccar dealers. Personally, after having this many turbos, etc. I would be getting a different truck. Try a new KW T660.

  9. #59
    Bobtail Member
    Member Since
    Nov 2011
    Location
    Chicago, IL
    Trucker?
    7 Years
    Posts
    2
    Thanks
    0
    Thanked: 0 Times
    I have a Volvo 780 with cummins isx 450. I had all problems described above until I just turned the EGR off. Now is running better, it gets good fuel mileage 6.8-7.2 average.

  10. #60
    Bobtail Member
    Member Since
    Nov 2011
    Trucker?
    16 Years
    Posts
    4
    Thanks
    0
    Thanked: 0 Times
    I have 9 of these trucks. That sounds like it might be the turbo. In these trucks the turbo will stick, so some times it will pull really good then nothing! Did they check the turbo actuator or the boots from the air to air.

Page 6 of 7 FirstFirst ... 4567 LastLast