Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Light Load Member rrw811's Avatar
    Member Since
    Dec 2011
    Location
    WI
    Trucker?
    0-1 Year
    Posts
    67
    Thanks
    53
    Thanked: 11 Times

    2005 isx exhaust manifold conversion? turbo issues

    Hi there, does anyone know if after deleting the egr on my 2005 isx 565, if i could bolt a pre egr isx exhaust manifold and turbo on it? I know id have to delete the vgt. Running 30 psi of boost on flat ground seems pointless with this vgt, just looking to replace it with something more simple and reliable. What got me thinking about this is after unloading, I started the truck, I noticed it sounded differant, as soon as i got on the road I noticed i could only get about 8 psi of boost and the egt was 800-900, being empty 450 would be normal. I pulled over and discovered the actuator on the turbo wasn't moving , I continued the 130 miles home, about 40 miles from home, the turbo spooled up, egts dropped, I'm thinking that solenoid that controls air to the actuator was acting up, I've started it a few times in the shop since I got home, works good. I'd still like to get rid of it, Any input is appreciated!

  2. #2
    NRG
    NRG is offline
    Light Load Member NRG's Avatar
    Member Since
    May 2010
    Location
    Montreal QC
    Trucker?
    12 Years
    Age
    37
    Posts
    140
    Thanks
    4
    Thanked: 23 Times
    Quote Originally Posted by rrw811 View Post
    Hi there, does anyone know if after deleting the egr on my 2005 isx 565, if i could bolt a pre egr isx exhaust manifold and turbo on it? I know id have to delete the vgt. Running 30 psi of boost on flat ground seems pointless with this vgt, just looking to replace it with something more simple and reliable. What got me thinking about this is after unloading, I started the truck, I noticed it sounded differant, as soon as i got on the road I noticed i could only get about 8 psi of boost and the egt was 800-900, being empty 450 would be normal. I pulled over and discovered the actuator on the turbo wasn't moving , I continued the 130 miles home, about 40 miles from home, the turbo spooled up, egts dropped, I'm thinking that solenoid that controls air to the actuator was acting up, I've started it a few times in the shop since I got home, works good. I'd still like to get rid of it, Any input is appreciated!
    You would have to delete the EGR programming from the ECM as well as VGT if you'll go for a full conversion. After you good for swapping your ex. manifold, turbo and physically removing your egr components valve and cooler.

  3. #3
    Light Load Member rrw811's Avatar
    Member Since
    Dec 2011
    Location
    WI
    Trucker?
    0-1 Year
    Posts
    67
    Thanks
    53
    Thanked: 11 Times
    Thanks for the advice NRG! The egr is already deleted. After talking to some people I guess a better question would be, in referring to my first post, is it normal for an isx with a variable turbo to run between 29-31 lbs of boost pulling a refer at 80000 lbs on flat road with little to no wind? It just doesn't seem right, when the old style turbos can accomplish the same work with less then half of that boost. Is it possible that the electric box that controls air to the turbo actuator is screwed up? Any advice is always appreciated. Thank you!

  4. #4
    NRG
    NRG is offline
    Light Load Member NRG's Avatar
    Member Since
    May 2010
    Location
    Montreal QC
    Trucker?
    12 Years
    Age
    37
    Posts
    140
    Thanks
    4
    Thanked: 23 Times
    Quote Originally Posted by rrw811 View Post
    Thanks for the advice NRG! The egr is already deleted. After talking to some people I guess a better question would be, in referring to my first post, is it normal for an isx with a variable turbo to run between 29-31 lbs of boost pulling a refer at 80000 lbs on flat road with little to no wind? It just doesn't seem right, when the old style turbos can accomplish the same work with less then half of that boost. Is it possible that the electric box that controls air to the turbo actuator is screwed up? Any advice is always appreciated. Thank you!
    No it's not normal. At your situation it should be around 5-10psi not 30! My boost dropped to 30 -32 at max, goes up to 35 if i WOT at low rpm in high gear. That's about 5psi less then when I had my egr working. Did you do a pressure test for boost leaks? How is your EGTs? The VG actuator could be the reason too. First thing, build air, shut off the truck and check for air leaks around it.
    Last edited by NRG; 04.01.2012 at 06.33 PM.

  5. The Following User Says Thank You to NRG For This Useful Post:


  6. #5
    Light Load Member rrw811's Avatar
    Member Since
    Dec 2011
    Location
    WI
    Trucker?
    0-1 Year
    Posts
    67
    Thanks
    53
    Thanked: 11 Times
    No I didn't check for boost leaks, I thought if I did have any, it might be a good thing at this point! My boost hasn't changed much at all with the egr delete. My egt run about 500 and hit 900 on a good pull, and never exceed 950. I will check for leaks in line from turbo to electric control box. Thank you, and any more info is always appreciated.

  7. #6
    NRG
    NRG is offline
    Light Load Member NRG's Avatar
    Member Since
    May 2010
    Location
    Montreal QC
    Trucker?
    12 Years
    Age
    37
    Posts
    140
    Thanks
    4
    Thanked: 23 Times
    Quote Originally Posted by rrw811 View Post
    No I didn't check for boost leaks, I thought if I did have any, it might be a good thing at this point! My boost hasn't changed much at all with the egr delete. My egt run about 500 and hit 900 on a good pull, and never exceed 950. I will check for leaks in line from turbo to electric control box. Thank you, and any more info is always appreciated.
    I would def. get the pressure test done and the VG actuator checked.

  8. #7
    Light Load Member rrw811's Avatar
    Member Since
    Dec 2011
    Location
    WI
    Trucker?
    0-1 Year
    Posts
    67
    Thanks
    53
    Thanked: 11 Times
    Well I pulled the actuator off, the vanes on the turbo move free and easy. The actuator seems good, no binding or anything. I pulled the air line off the control valve and supplied air through the line to the turbo, no leaks, everything seems fine. I'm still thinking the control box may be faulty. I havnt had the cac checked yet. What are others running for boost with these variable turbo isx? 5-10 lbs on flat land sounds better then 30! Is it possible that I'm needing the extra boost due to the big flat front end and low roof on my 9900? Seems unlikely, what are you guys with petes and such running for boost? Thank you!

  9. #8
    Medium Load Member
    Member Since
    Jan 2010
    Location
    hanover pa
    Trucker?
    8 Years
    Posts
    618
    Thanks
    4
    Thanked: 75 Times
    kinda sound's like the muffler is plugged up i have a 9900 but i have a cat im like 5-10 pounds on the flat's

  10. #9
    Light Load Member rrw811's Avatar
    Member Since
    Dec 2011
    Location
    WI
    Trucker?
    0-1 Year
    Posts
    67
    Thanks
    53
    Thanked: 11 Times
    That would make sense, but I put a pittsburgh power muffler on not to long ago, didn't make a difference. This trucks exhaust system is super long, it goes down under the frame behind the cab, then loops back forward where it splits to each stack, I've often wondered even with the free flow muffler, there has to be a lot of restriction just because of the length.

  11. #10
    Road Train Member
    Member Since
    Apr 2009
    Location
    aircap, Ks.
    Trucker?
    WannaBe
    Age
    44
    Posts
    2,543
    Thanks
    706
    Thanked: 2,525 Times
    How are you checking for leaks?

    Take a squirt bottle with soapy water and squirt down everything. Even little leaks are blatant at idle.

    What kinda smoke are you getting if any?

Page 1 of 2 12 LastLast