Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Results 1 to 7 of 7
  1. #1
    Bobtail Member nitrouskid2601's Avatar
    Member Since
    Mar 2011
    Location
    Fairfield IL
    Trucker?
    9 Years
    Posts
    15
    Thanks
    4
    Thanked: 2 Times

    davco 382 fuel prosessor

    having a slight issue with the fuel processor on my 03 columbia with 12.7 detroit.

    noticed a couple weeks ago that the bowl was empty, it does run fine down the road. have had it die just after starting it a couple times and had to put some fuel in the filter to get it started, changed the filter the first time it done this thinking the filter was leaking at the bottom. this didnt help

    i went to freightliner monday and got another new filter thinking mabye i had the wrong one or it was defective, they changed it for me and said that should fix the problem. today it was empty again and it died and i had to put fuel in the filter once again to get it restarted.

    im new to this type of filter setup and dont really know where to start looking, anybody have any suggestions?

    any ideas would be appreciated, thanks JR..

  2. #2
    Medium Load Member
    Member Since
    Jan 2010
    Location
    hanover pa
    Trucker?
    8 Years
    Posts
    620
    Thanks
    4
    Thanked: 76 Times
    i think it has a check valve in it so the fuel don't run back

  3. The Following User Says Thank You to little cat 500 For This Useful Post:


  4. #3
    Light Load Member
    Member Since
    Jun 2010
    Location
    Central Maine
    Trucker?
    16 Years
    Posts
    163
    Thanks
    37
    Thanked: 22 Times
    I'm thinking that it must be sucking air from somewhere allowing the fuel to be drawn down out of the filter.......
    I just changed the filter on mine the other day and i had a bugger of a time getting the o-ring to seal properly.......i would start the truck, step out and look at the filter and i could watch the fuel level dropping.....took me 3-4 tries before i got it......also make sure the o-ring on the top vent cap is good and tight....

    Hope this helps and good luck!!

  5. The Following User Says Thank You to Floyd For This Useful Post:


  6. #4
    BCR
    BCR is offline
    Bobtail Member
    Member Since
    Feb 2011
    Trucker?
    11 Years
    Posts
    15
    Thanks
    0
    Thanked: 2 Times
    There is a check valve in the side where the inlet line goes into housing. They sometime get trash in them, its just a ball and spring. If you have a leak, (dont have to be a visible fuel leak), in the lines AFTER the filter they will leak back also. Just like holding your finger on the end of a straw, when you release it with liquid in it, it runs out. I think, cant remember too well, there is another restricter/check valve on the back of the head return line that causes leakdown also, but it aint cheap!

  7. The Following User Says Thank You to BCR For This Useful Post:


  8. #5
    Bobtail Member nitrouskid2601's Avatar
    Member Since
    Mar 2011
    Location
    Fairfield IL
    Trucker?
    9 Years
    Posts
    15
    Thanks
    4
    Thanked: 2 Times
    thanks for the replies, this morning i took the inlet line off the filter housing poured some fuel in the top and it was slowly dribbling out the inlet fitting. so it looks like the check valve is leaking, should be an easy fix.

    i will take the valve out and clean it this weekend, im convinced that this will fix it.

    thanks again, JR..

  9. #6
    Heavy Load Member
    Member Since
    Mar 2011
    Location
    Florida
    Trucker?
    0-1 Year
    Posts
    834
    Thanks
    69
    Thanked: 253 Times
    The check valve is replaceable, go to a Freightliner dealer they should have one, or go google Davco's website and order it over the phone.

  10. #7
    Bobtail Member nitrouskid2601's Avatar
    Member Since
    Mar 2011
    Location
    Fairfield IL
    Trucker?
    9 Years
    Posts
    15
    Thanks
    4
    Thanked: 2 Times
    just an update, took it apart today and the check valve had some crud stuck in it. replaced it with a new one, also put on a new clear cover on the filter housing.

    its good as new again, thanks for the replies!

  11. The Following User Says Thank You to nitrouskid2601 For This Useful Post: