Trucking Jobs New Driver Jobs Flatbed Jobs Tanker Jobs Refrigerated Jobs Auto Hauler Jobs
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21
  1. #11
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,583
    Thanks
    24
    Thanked: 1,149 Times
    Quote Originally Posted by sleepingbear View Post
    so.
    Volvo dealer is saying that the 5volt was traced to the egr#2.

    my response- If you replace the egr#2 , will it solve the "zero" reading on my oil pressure dash gauge? (because they say it operates off the same circuit.)
    If I'm not throwing any fault codes for EGR, why would replacing the unit solve the 'short' problem. should'nt they instead look for the 'short' problem?
    disconnect EGR2 sensor to be sure


  2. #12
    Medium Load Member
    Member Since
    Mar 2007
    Posts
    400
    Thanks
    40
    Thanked: 95 Times
    Volvo Dealer called early this monring to say that egr#1 is also bad.

    Fantastic! i have a receipt for that one! Replaced just 40 days ago.

  3. #13
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,583
    Thanks
    24
    Thanked: 1,149 Times
    I cant be sure. Hook the DVOM to any sensor to monitor 5V supply, turn ign on and disconnect all sensors one by one to find bad one.

    EGR pos sensor is a variable resistor aka TPS

  4. #14
    Medium Load Member
    Member Since
    Mar 2007
    Posts
    400
    Thanks
    40
    Thanked: 95 Times
    two egr's replaced. One charge air cooler. $3500.

    now, four days later, truck shuts down for 'low coolant'

    I know when the egr's are replaced, they have to drain the coolant.

    I drove 900 miles after the repairs(finished friday morning) before the low coolant shutdown occurred this morning(omnday). Each day I was getting a whiff of the coolant smell. I figured they spill some on the engine, and when it warmed up, it vaporized. I 'm not seeing any visible sign's of leaking. I'm not seeing any white smoke out of the stack. I filled the reservoir with about 1/2 gallon of water and completed my delivery(about 170 miles of driving) . no shutdown since.

    a question.... Could there be an 'egr installation error' that could cause the leaking?

    btw, the power is better now that the repairs were made. Not exactly flying up hills, but it is better than prior to repair.

  5. #15
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,583
    Thanks
    24
    Thanked: 1,149 Times
    Quote Originally Posted by sleepingbear View Post
    two egr's replaced. One charge air cooler. $3500.

    now, four days later, truck shuts down for 'low coolant'

    I know when the egr's are replaced, they have to drain the coolant.

    I drove 900 miles after the repairs(finished friday morning) before the low coolant shutdown occurred this morning(omnday). Each day I was getting a whiff of the coolant smell. I figured they spill some on the engine, and when it warmed up, it vaporized. I 'm not seeing any visible sign's of leaking. I'm not seeing any white smoke out of the stack. I filled the reservoir with about 1/2 gallon of water and completed my delivery(about 170 miles of driving) . no shutdown since.


    a question.... Could there be an 'egr installation error' that could cause the leaking?

    btw, the power is better now that the repairs were made. Not exactly flying up hills, but it is better than prior to repair.
    Yes, coolant leak to exaust. wrong egr cooler installation

  6. #16
    Bobtail Member
    Member Since
    May 2013
    Trucker?
    2 Years
    Posts
    3
    Thanks
    0
    Thanked: 0 Times
    Quote Originally Posted by xiipercent View Post
    so.
    Volvo dealer is saying that the 5volt was traced to the egr#2.

    my response- If you replace the egr#2 , will it solve the "zero" reading on my oil pressure dash gauge? (because they say it operates off the same circuit.)
    If I'm not throwing any fault codes for EGR, why would replacing the unit solve the 'short' problem. should'nt they instead look for the 'short' problem?

    Did you solve the problem with the 0 on your dashboard

  7. #17
    Medium Load Member
    Member Since
    Mar 2007
    Posts
    400
    Thanks
    40
    Thanked: 95 Times
    yes- they changed the oil pressure sensor that day... 1/27/12-

    all good since then.

  8. #18
    Bobtail Member
    Member Since
    May 2013
    Trucker?
    2 Years
    Posts
    3
    Thanks
    0
    Thanked: 0 Times
    Hmm..
    The mechanic told me that my sensor is good and i have msg. Oil prsuare communication error
    And he said that can be broken wire betwen cluster and the engine but i am wondering meybe mechanic is wrong about my sensor

  9. #19
    Road Train Member Pablo-UA's Avatar
    Member Since
    Oct 2010
    Location
    Borispol, Ukraine
    Trucker?
    Trucking Industry
    Posts
    6,583
    Thanks
    24
    Thanked: 1,149 Times
    Quote Originally Posted by azja View Post
    Hmm..
    The mechanic told me that my sensor is good and i have msg. Oil prsuare communication error
    And he said that can be broken wire betwen cluster and the engine but i am wondering meybe mechanic is wrong about my sensor
    Bad J1708 datalink wiring (400-401 wires ore gray/orange tw. pair)

  10. #20
    Bobtail Member
    Member Since
    May 2013
    Trucker?
    2 Years
    Posts
    3
    Thanks
    0
    Thanked: 0 Times
    Eh i dont wanna put my hands into it becouse i dont wanna break anything
    But thx
    I need find a good mechanic who can fix that not only take money for nothing

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •