13 speed stuck in high range

Discussion in 'Trucks [ Eighteen Wheelers ]' started by rydr, Jun 27, 2021.

  1. rydr

    rydr Light Load Member

    114
    82
    Jan 8, 2019
    0
    2001 w900 stuck in high range, where do I start? I dont think its anything mechanical as the transmission shifts fine and doesn't make any noise while driving. Sometimes I can get it out of high range but it will just get stuck in neutral, it never goes into lo range, but I can flip the selector up and hear it click into high range. I have a load to deliver Tuesday, dont think thats happening now.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. skallagrime

    skallagrime Road Train Member

    1,595
    3,109
    Apr 10, 2012
    Indiana
    0
    Check your air lines on the trans one may be blocked pinched or cut

    Or if you recently had it worked on, they may have hooked up the lines wrong

    Or if your truck throws a lot of oil, the valve may be sticking
     
    Hulld Thanks this.
  4. FLHT

    FLHT Medium Load Member

    413
    385
    Aug 2, 2014
    0
    What kind of transmission ?
    Worn shifting forks ?
     
  5. AModelCat

    AModelCat Road Train Member

    22,347
    104,979
    Jul 7, 2015
    Canuckistan
    0
    If the air side checks out ok it may be internal. A broken synchro pin can keep it stuck in 1 range.
     
    Dino soar, wore out and BoxCarKidd Thank this.
  6. rydr

    rydr Light Load Member

    114
    82
    Jan 8, 2019
    0
    The transmission was rebuilt then the truck sat for 3 or 4 years. Pulled it out of the parts truck and has been in this truck for about 6 months
     
  7. BoxCarKidd

    BoxCarKidd Road Train Member

    3,499
    4,849
    Aug 26, 2014
    0
    You have two rubber lines to the piston housing on the top right of the transmission. Mark them. You should have air out of one in high and the other in low with about 60 PSI. If OK take the back cover off that piston. It should not be dry and rusty.
     
    Dino soar and spsauerland Thank this.
  8. rydr

    rydr Light Load Member

    114
    82
    Jan 8, 2019
    0
    I took the plunger out of the housing not rusted, the o rings looked fine not torn or missing. I put air to the housing with an air gun, I can hear it going to low and high range. Took it for a drive and it went into low range once, but at the next stop sign it got stuck in neutral and was only able to get into high range. Does this seem like a weak air valve?
     
  9. AModelCat

    AModelCat Road Train Member

    22,347
    104,979
    Jul 7, 2015
    Canuckistan
    0
    Wonder if the air regulator on the transmission is failing. Transmissions run at something like 70 PSI.
     
    Dino soar Thanks this.
  10. rydr

    rydr Light Load Member

    114
    82
    Jan 8, 2019
    0
    I used shop air at 120psi. I think im going to replace the slave and splitter valve tomorrow. Everything is closed around me today
     
  11. BoxCarKidd

    BoxCarKidd Road Train Member

    3,499
    4,849
    Aug 26, 2014
    0
    Check pressure to the active hose when it will will not shift. Sounds like broken pins as AModel mentioned.
    That other stuff is just throwing money at it if you do not do tests.
     
    spsauerland Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted