2012 peterbilt 587 grinding in gears 7 through 10

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Peterbiltutg, Sep 17, 2021.

  1. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    I just got the truck back from peterbilt and they changed the synchronizer. Truck drove good for two days then started grinding when shift from 7 through 10. It also grinds when I’m not shifting. Please help
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    After I got the truck back my ac compressor stopped spinning and I now have a coolant leak. Is any of that related to the problem?
     
  4. Ross_Tech

    Ross_Tech Light Load Member

    123
    111
    Aug 31, 2021
    Michigan
    0
    I would take it back to Peterbilt. Is it a 10 speed?
     
  5. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    Yes it is a 10 speed
     
  6. Ross_Tech

    Ross_Tech Light Load Member

    123
    111
    Aug 31, 2021
    Michigan
    0
    I would think it would grind in 5-6 upshift or 6-5 downshift shift if something was wrong with the synchros. Either way, I would take it back to Peterbilt. What were the symptoms when you brought it to them?
     
  7. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    it was doing the same thing, grinding in the upper gears. Not just when you’re shifting, it grinds when you’re in gear as well. When I picked up the truck the ac compressor stopped working and it was leaking coolant. Could that be related to the issue?


     
  8. Ross_Tech

    Ross_Tech Light Load Member

    123
    111
    Aug 31, 2021
    Michigan
    0
    The AC issue is not related to the trans issue, but it is possible the tech could have disturbed an existing wiring problem, or left some wiring disconnected, but it's hard to say. Its the same with the coolant leak, it's not going to be related to the trans issue, but if for some reason the tech disconnected any coolant lines, there could be a leak now. But that's pretty unlikely. I'm not too familiar with Pete's, but I can't see a reason they would need to disconnect any coolant lines to get to the back box of the trans.
     
  9. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    Could it be the leveling valve?
     
  10. Ross_Tech

    Ross_Tech Light Load Member

    123
    111
    Aug 31, 2021
    Michigan
    0
    I would take it back to Peterbilt.
     
  11. Peterbiltutg

    Peterbiltutg Bobtail Member

    6
    0
    Sep 17, 2021
    0
    Just found out there was no air in the air bags and my ride height was too low
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted