2013 579 electrical problems

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by 579purplepete, Oct 2, 2019.

  1. 579purplepete

    579purplepete Bobtail Member

    3
    0
    Oct 2, 2019
    0
    Any help would be greatly appreciated truck is a 579 Cummins engine the issue is we lose power to the cab and then you can actually get power to the ground side of the frame. DisconnectI ng the batteries then putting a jump box on it will get it to fire back up but then you take the chance of being brokedown on the side of the road. The interior lights do flicker and we have noticed some of the accessories have stopped working (CIG lighter acc charging ports radio cut out at times) thanks in advance..
     
  2. Goodysnap

    Goodysnap Road Train Member

    1,630
    3,141
    Jul 12, 2017
    0
    If you truly have power on the frame I would get this truck in the shop before it burns down. Somewhere you have a main unfused hot cable touching ground. A potentially dangerous situation if not tended to.
     
    pushbroom Thanks this.
  3. BoxCarKidd

    BoxCarKidd Road Train Member

    2,658
    3,273
    Aug 26, 2014
    0
    This goes back over 35 years and a truck had similar problems. ( I did not see this first hand! ) It would not conduct electricity through a section of the frame rail. They extended wires past that area and it worked.
    Electric companies have wrenches that do not conduct electricity. I do not know how that works or how a frame rail section could be like that. Just sharing the idea. If it is under warranty the manufacturer should be responsible.
     
  4. Rounded_nut

    Rounded_nut Light Load Member

    92
    103
    Feb 25, 2018
    0
    Just a thought, do you have jump posts on it? Could be the hot is making contact ...
     
  • Draft saved Draft deleted