2015 kenworth t680 heater not blowing hot

Discussion in 'Flatbed Trucking Forum' started by King without a crown, Jan 16, 2020.

  1. King without a crown

    King without a crown Bobtail Member

    7
    0
    Nov 14, 2019
    0
    Can anyone help me out on this. My heater doesn’t work when I need it and my ac does the same. When It’s warm outside the heater works and when it’s cold outside the ac works. It just blows but the temperatures aren’t doing what I need them to do. Has anything like this happened to any of you ??
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. brianv31

    brianv31 Light Load Member

    172
    375
    Mar 5, 2010
    LeRoy, IL
    0
    FYI there's a Kenworth forum in the Garage section, may get more traction on responses there
     
  4. King without a crown

    King without a crown Bobtail Member

    7
    0
    Nov 14, 2019
    0
    Thanks Brian. I’ll repost it there.
     
  5. overdrive112

    overdrive112 Bobtail Member

    5
    1
    Aug 3, 2019
    USA
    0
    Could it be the heater core valve
     
  6. King without a crown

    King without a crown Bobtail Member

    7
    0
    Nov 14, 2019
    0
    I doubt it’s the core valve. And that’s just because it worked yesterday when I didn’t need it. When it’s warm outside the heater works and the ac doesn’t. and when it’s cold outside only the ac works.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted