2015 Kenworth t680

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by TESSIE, May 20, 2022.

  1. TESSIE

    TESSIE Bobtail Member

    8
    1
    May 20, 2022
    0
    Help, I have had to replace my power steering pump three times in the last six months on my 2015 Kenworth t680 . three different shops so it is not mechanic error. is there anything else i should be looking at.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. spsauerland

    spsauerland Road Train Member

    4,115
    10,484
    May 31, 2010
    West Harrison, In
    0
    If MX probably air compressor bearing failing.
     
    Goodysnap Thanks this.
  4. TESSIE

    TESSIE Bobtail Member

    8
    1
    May 20, 2022
    0
    thanks I will check that . i was told it may be my gear box and i cant find one anywhere
     
  5. Lyle H

    Lyle H Heavy Load Member

    898
    1,750
    Apr 16, 2014
    0
    Is the pump still mounted in the original position from the factory?
    I had a problem with my power steering fluid getting too hot because the pump was mounted too close to the radiator from the factory. Kenworth came out with new mounting brackets that moved the pump further back away from the radiator. Solved my hot fluid problem.
    It may be your issue too.
     
    Last edited: May 21, 2022
  6. Lyle H

    Lyle H Heavy Load Member

    898
    1,750
    Apr 16, 2014
    0
    I should have been more clear in my above response.
    It’s the reservoir that was relocated.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted