2015 Prostar wont go past 5th gear fault code 71

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by A T Trans Inc Texas, Nov 30, 2021.

  1. A T Trans Inc Texas

    A T Trans Inc Texas Bobtail Member

    9
    1
    Nov 30, 2021
    0
    Truck has run fine until it wouldn't go into reverse. My alternator voltage was down. I replaced batteries. Not sure if I connected batteries correctly. Not negative to positive. I've heard before that the first battery should some how be connected by itself or some along those lines. I've read through the other threads regarding this issue. I paid a service truck to come out yesterday but I know more about this truck than he does. So I'm still broke down at the truck stop diagnosing the problem myself. Could it be low on fluid or need clutch adjustment. Some please help.
    @Heavyd, can you help?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. pavrom

    pavrom Road Train Member

    2,264
    4,553
    Apr 29, 2012
    NE illinois
    0
    .
     
    Last edited: Nov 30, 2021
  4. flood

    flood Road Train Member

    3,543
    2,717
    Dec 25, 2010
    0
    If it's running 1-5 fine (low range) but won't go to 6-10 (high range) most likely it's the range solonoid.. ...

    On most trucks it takes about 1 hr to change it...

    What's the full code.....?
    Spn #
    Fni #
    Sa #
     
  5. A T Trans Inc Texas

    A T Trans Inc Texas Bobtail Member

    9
    1
    Nov 30, 2021
    0
    It only shows code 71 and 27. No more codes. Thanks for reply
     
  6. flood

    flood Road Train Member

    3,543
    2,717
    Dec 25, 2010
    0
    are you using the self diagnostic thru the dash...
    With the key on (not started) press the cruise control "on" and "accelerate" at the same time. Guages well swipe and the display will show all active and inactive full codes...
     
  7. A T Trans Inc Texas

    A T Trans Inc Texas Bobtail Member

    9
    1
    Nov 30, 2021
    0
    I changed range sensor. Still only goes to 5th gear. Codes are below. Thanks.
     

    Attached Files:

  8. A T Trans Inc Texas

    A T Trans Inc Texas Bobtail Member

    9
    1
    Nov 30, 2021
    0
  9. A T Trans Inc Texas

    A T Trans Inc Texas Bobtail Member

    9
    1
    Nov 30, 2021
    0
    I changed range solenoid and still 5th gear only.
     
  10. flood

    flood Road Train Member

    3,543
    2,717
    Dec 25, 2010
    0
    the #2653 is the low beam driver side.
    The #560 is your problum "transmission driveline engaged"... not a clue what that means
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted