96 w900 jakes and cruise

Discussion in 'Kenworth Forum' started by Asanchez, Mar 24, 2021.

  1. Asanchez

    Asanchez Bobtail Member

    6
    2
    May 17, 2020
    0
    does anybody know how to wire the 3 prong clutch switch on a Kenworth.? Jakes and cruise Switch’s have no power. Clutch switch is new. Has 2 sets of wires one says clutch switch common and the other wire says clutch switch norm open but clutch switch has another prong that says open

    1996 Kenworth w900
    12.7 Detroit
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. AModelCat

    AModelCat Road Train Member

    21,355
    96,964
    Jul 7, 2015
    Canuckistan
    0
    I believe you only use 2 terminals. Its more or less a generic microswitch with a Common pin and the other 2 are Normally Open and Normally Closed.

    Not 100% sure but I'm thinking you'd want to use the Common and the Normally Open pin. That way the clutch pedal would keep the switch closed and then open (break) the circuit when you press in the clutch.
     
    Bean Jr. Thanks this.
  4. Asanchez

    Asanchez Bobtail Member

    6
    2
    May 17, 2020
    0
    Ok thank you I’ll try it. Are these wires supposed to be grounds or hot wires also? Never had to fight this problem so I’m all confused
     
  5. AModelCat

    AModelCat Road Train Member

    21,355
    96,964
    Jul 7, 2015
    Canuckistan
    0
    That, unfortunately, I can't answer. I haven't wrenched on trucks in several years so I don't remember.
     
  6. Asanchez

    Asanchez Bobtail Member

    6
    2
    May 17, 2020
    0
  7. Hulld

    Hulld Road Train Member

    2,695
    5,780
    Oct 19, 2015
    Upstate NY
    0
    I don’t really believe they are hots or grounds per say.
    It’s mainly just a switch in series that interrupts the completed circuit to shut the Jake off... if that makes any sense to you?
    With out a schematic I believe the way @AModelCat said to wire the switch makes perfect sense and I would start with that.
     
  8. Asanchez

    Asanchez Bobtail Member

    6
    2
    May 17, 2020
    0
    @Hulld that makes sense what you are say. I’ll try to wire it again and see what happens been fighting this problem for a while now
     
    Hulld Thanks this.
  9. Hulld

    Hulld Road Train Member

    2,695
    5,780
    Oct 19, 2015
    Upstate NY
    0
    Give it a try and check back.
    Many will try to help you here.
     
  10. Asanchez

    Asanchez Bobtail Member

    6
    2
    May 17, 2020
    0
    @AModelCat and @Hulld finally found the time to mess with the wiring on the clutch switch in between work and rebuilding a cat motor. Plugged common up and norm open started the truck still no power to cruise or jakes but then the truck would not shut off. So then I plugged norm open to just open and truck shut off I’m at a loss here
     
  11. Roger McG

    Roger McG Light Load Member

    128
    144
    Oct 22, 2016
    western mass
    0
    I think you probably ought to check the speed sensors on rear of transmission
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted