c-15 accert loosing prime

Discussion in 'Trucks [ Eighteen Wheelers ]' started by 24valve puller, Jan 10, 2016.

  1. 24valve puller

    24valve puller Medium Load Member

    399
    89
    Sep 8, 2007
    N.E. Oh
    0
    Buddies accert is loosing prime and is getting harder to start. Replaced the check valve at the fuel filter and no difference. Runs fine after you get it running. Will start and run then shut off. He just changed the secondary filter and I'm sure its a cat filter.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. swaan

    swaan Road Train Member

    2,940
    4,303
    Jul 12, 2009
    BC canada
    0
    He did fill the filter up with fuel before screwing it back on right??
     
  4. 24valve puller

    24valve puller Medium Load Member

    399
    89
    Sep 8, 2007
    N.E. Oh
    0
    Its run 1500 mi since he changed the filter. He filled the filter. That would keep it from starting at 1st but not every time he shuts it off
     
  5. swaan

    swaan Road Train Member

    2,940
    4,303
    Jul 12, 2009
    BC canada
    0
    Ok just checking .
    Ur post was not exaclly clear.
    Mmmmmmm
    So now it's hard to start after its shut off overnight?
     
  6. Cat sdp

    Cat sdp . .

    15,104
    38,751
    Apr 8, 2012
    Orion's Belt
    0
    I would look at the fuel lines ....mine were junk and the hard starting was one of the first symptoms ...

    It would have to be on the suction side of the transfer pump....apparently it was sucking air right threw the line ...
     
  7. 062

    062 Road Train Member

    4,763
    9,757
    Oct 20, 2013
    0
    Does it have the hand primer? They're known to go bad.
     
    bubbanbrenda Thanks this.
  8. 24valve puller

    24valve puller Medium Load Member

    399
    89
    Sep 8, 2007
    N.E. Oh
    0
    Hard to start after a few hrs or will start then shut off. It does have the hand pump, he was thinking that could be the problem. Its an 05 with 1 million on it, fuel lines are prolly not the best
     
  9. swaan

    swaan Road Train Member

    2,940
    4,303
    Jul 12, 2009
    BC canada
    0
    It's suckin air somewhere.
    I would put new suction and return lines on with that kind of mileage
     
  10. bubbanbrenda

    bubbanbrenda Road Train Member

    1,388
    649
    Feb 27, 2011
    Middletown,Oh.
    0
  11. Chris50

    Chris50 Medium Load Member

    346
    213
    Jun 21, 2010
    Florida
    0
    My Acert had this problem once, it was the fuel transfer pump.
     
    josh polk Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted