Cat C15 oil pressure issue

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Dave1837, May 26, 2020.

  1. Dave1837

    Dave1837 Light Load Member

    297
    610
    Nov 16, 2019
    Pennsylvania
    0
    I drove a 2007 379 with a C15 ACERT, it had a 625 until it scattered around 898k. A brand new 550 was installed about 13k ago. Today when I left my house I noticed my oil pressure was around 40 psi after a 20 minute warm up, as opposed to the normal 60-65. As the oil warmed up it dropped to about 25. I pulled over and let it idle, then it dropped down to 10. Oil is full, oil temp is normal, no knocking or pinging is occurring. I drove it to my load point a few miles away and shut it down again, then turned the key on to self test the gauges. With the key on, engine off, the gauge will jump up to 75 psi, then when I start it, it will drop back down to 10. Faulty sensor?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. baha

    baha Road Train Member

    3,400
    1,912
    Jul 25, 2013
    ga
    0
    Thats what it seems to be, later it may set off the stop eng. light and shut off your eng.
     
    A5¢ and Dave1837 Thank this.
  4. 062

    062 Road Train Member

    3,228
    5,883
    Oct 20, 2013
    0
    Need to put a manual gauge on it to confirm. ASAP
     
    TGUNKEL, A5¢, Doealex and 1 other person Thank this.
  5. Dave1837

    Dave1837 Light Load Member

    297
    610
    Nov 16, 2019
    Pennsylvania
    0
    It did this once before but fixed itself after a few minutes. Taking it to a shop to have it checked out
     
  6. AModelCat

    AModelCat Road Train Member

    16,364
    68,046
    Jul 7, 2015
    Edmonton
    0
    Sounds like a gauge issue IMO but I'd definitely put a test gauge on it to make sure.
     
    A5¢ and Dave1837 Thank this.
  7. Dave1837

    Dave1837 Light Load Member

    297
    610
    Nov 16, 2019
    Pennsylvania
    0
    It was a bad sensor. My A/C stopped working as well on my way to the shop so I pulled over and found the belt was gone, shredded all through the engine bay. What a day
     
  8. Dave1837

    Dave1837 Light Load Member

    297
    610
    Nov 16, 2019
    Pennsylvania
    0
    Thank you, everybody for your input
     
    062 Thanks this.
  9. Chubby Fly

    Chubby Fly Medium Load Member

    569
    769
    Nov 25, 2019
    0
    yeah on my 379, i can tap the gauge and get a few more psi out of lol. Stock gauge is mechanical too. But i guess they wear out just like anything else
     
    650cat425 Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted