Comfort Pro Apu Issues (solved)

Discussion in 'Trucks [ Eighteen Wheelers ]' started by mitchtazz, Apr 12, 2014.

  1. Wenhardt79

    Wenhardt79 Bobtail Member

    1
    0
    Apr 28, 2019
    0
    ComfortPro Apu wont start manually just says main engine interlock. Checked all wire harnesses for breaks, repaired many broken or bad connections. Checked all the fuses including in line fuse for interlock relay, all good. Service light on CCU board flashes I did notice. Have power to controller mounted down by engine, everything seems to work fine when unit is in battery mode. Engine automatically comes on runs its course then shuts off. Other than that cant do nothing with it. What would be causing an issue that its not allowing me to start unit manually?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Den S.

    Den S. Bobtail Member

    3
    0
    May 10, 2019
    0
    What do I do when the APU just shuts off after an hour of use? I was using it just 2days prior and it was working just fine. This is a new truck so idk why it would just stop with no power at all! Not even lights on the screen. What should I do?
    I have to be back to work in 4days. I am praying that this can be fixed w/o too much hassle. But that's not presenting itself to be the case. For the fact, I HAVE ABSOLUTELY NO IDEA HOW-WHY-WHAT CAUSED THE THING TO JUST STOP GENERATING POWER!!!!
    Totally frustrating and mind boggling! Any advice, tips, information, tricks, answers, how to's, DIY. I am open to suggestions and grateful for ANY prompt response, but just as thankful to those of you who take the time to even reply! It is my Friday (literally) & I finally made it home after being on the road for 32 days straight. With no time off except for 2 layovers which lasted 34 hours long. Don't get me wrong...I probably wouldn't be food at any other job. Trucking is my life. I guess that's why this issue bothers me so much! It's something of a issue when I can't fix said problem NOR can I come up with a solution bc I have no idea what caused the power on the APU to just stop working! I want to go ahead and thank those of you in advance for taking the time out of your day to read (this absurdly long) detailed post!
    I understand that time is valuable so I will give it a rest for now...giving you guys to reply??? Again, I thank you SO MUCH for any help.
     
    Last edited: May 10, 2019
  4. WheresWaldo

    WheresWaldo Light Load Member

    107
    60
    Nov 23, 2016
    Oklahoma
    0
    So you have the interlock installed? If so pull the fuse for it and try to start. Should be the little yellow wire with a 5 amp fuse. (Or 2.5 fuse) With this you're possibly looking at a stuck relay coil for the interlock, or even worse a bad control module.
     
  5. WheresWaldo

    WheresWaldo Light Load Member

    107
    60
    Nov 23, 2016
    Oklahoma
    0
    So you don't have power at your display? First take your cover off your apu and make sure both plugs on the control module are fully pushed in. Also make sure you don't have a unplugged or damaged CAT5 cable (telephone looking wire) feeds into your display from the back of the display through your bunk and into your evaporator box. Also check and make sure your battery cables running from Apu to battery box haven't some how come loose and possibly damaged in drive line (I've seen this one before also due to bad installs.) Sorry for the rambling these are just a few things off the top of my head without having a first hand look.
     
  6. Trucker79928

    Trucker79928 Bobtail Member

    1
    0
    Jun 5, 2019
    0
    My comfort pro apu stops after cranking like 3 or 4 times. Then it says crank limit reached. What is it?
     
  7. WheresWaldo

    WheresWaldo Light Load Member

    107
    60
    Nov 23, 2016
    Oklahoma
    0
    Sounds like you lost prime. On your control panel for on off just hold that button down and it'll let you manual crank. Try not to let it crank for too long and give enough time in between 2 or 3 start attempts or you'll burn your starter up.
     
  8. Antonovich

    Antonovich Light Load Member

    133
    88
    May 11, 2019
    0
    So my Comfort Pro crapped out a few days ago. The only message I got was "Low Voltage". The APU starts and charges the batteries but no HVAC and the outlets do not work. Also I no longer get the "low voltage" message. When I press the AC button simply nothing happens. Took it to a Carrier dealer in Cleveland, they said it's a bad generator. A $2000 repair. Yeah, I'm a bit sceptical that they just happen to find the most expensive part as the cause of the issue.

    I have tools with me and a multimeter, but I'm not sure what to actually check. I'd appreciate any help.
     
  9. WheresWaldo

    WheresWaldo Light Load Member

    107
    60
    Nov 23, 2016
    Oklahoma
    0
    First you need to take the cover off your Apu and check your generator belt. If it's tight and not flopping around then you'll need to check A/c voltage at the generator, the breaker, and so on till you find your loss of voltage.
     
    bzinger Thanks this.
  10. Antonovich

    Antonovich Light Load Member

    133
    88
    May 11, 2019
    0
    How do I check voltage on the generator?
     
  11. WheresWaldo

    WheresWaldo Light Load Member

    107
    60
    Nov 23, 2016
    Oklahoma
    0
    Go to your evaporator box, under your bunk. Take the lid off, you'll see your CCU board with all the wires and everything plugged in, you'll see 3 wires black white and green on your board. Check voltage there on the black and white. (Apu needs to be on) if you're getting power there then it's not your generator. If no power you're either dealing with the a bad generator, breaker, or even possible a loose wire.

    That's the quickest way to give it a look and start narrowing down your problem.
     
    mhyn Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted