Cummins ISX 500 boost problems

Discussion in 'Trucks [ Eighteen Wheelers ]' started by FunkRider, Sep 26, 2010.

  1. bigguns

    bigguns Road Train Member

    2,409
    5,843
    Jun 13, 2013
    Omega,GA
    0
    Did the Cummins shop also supply a 5 gal. pail of KY jelly. If not you got taken.
     
  2. Terry prostar

    Terry prostar Bobtail Member

    5
    0
    Sep 30, 2016
    albefrta
    0

    did you find the trouble with your press spike 2008 cummins isx just did a delete and doing the same thing i have checked every thing 3 times i gong to burn it down lol
     
  3. Terry prostar

    Terry prostar Bobtail Member

    5
    0
    Sep 30, 2016
    albefrta
    0
    i have the same problem what did you do to fix it i have checked every help would be great
     
  4. pup

    pup Light Load Member

    171
    136
    Dec 3, 2011
    n.h.
    0
    the vgt turbochargers can fail internally & cause the low power. The moving parts within the exhaust section of the turbo fail & allow the turbo to randomly change its output.
     
  5. Terry prostar

    Terry prostar Bobtail Member

    5
    0
    Sep 30, 2016
    albefrta
    0
    most turbos includng vg once they fail u should find it in the play in the braing or see scuffing on eather side
     
  6. Elrojo10

    Elrojo10 Bobtail Member

    1
    0
    Sep 14, 2017
    0
    I have a 2013 pete with cummins isx 15. I have a problem with the manifold gauge ever since i bought this truck the gauge wont go past 20 psi. Has anybody had this problem? The truck has power to take off even if hauling 40+ thousand lbs. The problem is when going uphill!
     
  7. pushbroom

    pushbroom Road Train Member

    1,152
    3,984
    Sep 1, 2012
    0
    Any check engine lights on? They should be with that low of boost. The intake manifold pressure sensor can plug up with soot and may need to be cleaned.
     
    spsauerland Thanks this.
  8. djstransport

    djstransport Bobtail Member

    2
    0
    Oct 29, 2018
    0
    Wouldn’t it throw a code. Mine just says boost pressure
     
  9. RoadRanger^^

    RoadRanger^^ Light Load Member

    57
    23
    Apr 17, 2018
    Columbus, OH
    0
    Okay i’m here too. I got cummins isx 15 w 500hp. This is crazy it’s giving me the code SPN 102 FMI 18 the light seem to come only when climbing hill and right away when i took my foot of the pedal is turning off. I have egr and dpf delete almost 3 years. New turbo on 600k now i have 900k but rebuild the engine on 800k. I searched online and called the cummins it says might be the intake manifold pressure sensor which i did replaced today, but naah again same when i climb hill cel its coming on. The thing is i have boost gauge and max is to 60 but my boost under load or even empty when going uphill is not going more the. 16-17. I don’t see any smoke coming the engine is running fine, my fuel miliage right now 7.8 because of my light loads but usualy around 7.2. I can tell that im loosing boost somehow somewhere ? Where should i start ? Maybe actuator? This drives me crazy. Thanks!
     
  • Draft saved Draft deleted