Derate to 5mph crisis - regen not clearing codes for some reason

Discussion in 'Freightliner Forum' started by PermanentTourist, May 10, 2019.

  1. PermanentTourist

    PermanentTourist Medium Load Member

    436
    363
    Nov 9, 2016
    48 states + Canada
    0
    Stuck in PA under a load with 5mph derate. It started out with the SPN 3364 FMI 2 (bad DEF quality, conversion low) and associated derate codes. I ran a regen or two, and the SPN 3364 cleared. But the SPN 5246 derate codes are still there! And now there is SPN 5397 FMI 31 - too many regens?!
    20190510_223416.jpg

    The weird thing is, I'm getting a really good NOX conversion rate, 80% or so, while regening. Shouldn't it be enough to clear the codes? Is the SPN 5297 the problem now?

    20190510_223428.jpg


    This truck has always had a SPN 3364 issue when hauling 40000lb+ over hilly terrain, but usually just running it clears it up in a few miles. Not tonight...

    I really don't want spend $$$ calling out a guy with a laptop when I myself am a guy with a laptop. Any advise?
     
  2. Dave_in_AZ

    Dave_in_AZ Road Train Member

    17,567
    43,105
    May 4, 2015
    0
    You have a legit hardware or sensor problem. Gonna have to get something fixed / changed.

    When mine went to stop engine / 5 mph, it turned out to be a wire in the main after treatment wiring harness went kaput. 2 days later it was fixed after being towed in.

    @bzinger just had his towed in for 5 mph derate / stop engine with bad DEF tank issue.

    Might wanna start looking for a decent tow service and where a dealer is.
     
    speedyk and bzinger Thank this.
  3. devedo

    devedo Light Load Member

    61
    24
    Aug 11, 2015
    0
    If ya got a manual unplug your speed sensor at the back of the trans. Itll get ya unloaded but youll lose your speedo
     
    Dave_in_AZ and PermanentTourist Thank this.
  4. bzinger

    bzinger Road Train Member

    9,728
    25,718
    Dec 10, 2014
    omaha , ne
    0
    Bad def tank heater valve .
     
    Dave_in_AZ Thanks this.
  5. PermanentTourist

    PermanentTourist Medium Load Member

    436
    363
    Nov 9, 2016
    48 states + Canada
    0
    Is there a DDDL parameter that I can check to verify that?
     
    bzinger Thanks this.
  6. bzinger

    bzinger Road Train Member

    9,728
    25,718
    Dec 10, 2014
    omaha , ne
    0
    Sorry I dont know enough about it to say .
     
    PermanentTourist Thanks this.
  7. PermanentTourist

    PermanentTourist Medium Load Member

    436
    363
    Nov 9, 2016
    48 states + Canada
    0
    I'm worried that's gonna confuse my corporate elog qualcomm box. It won't put me on drive, and then I will be getting calls from the logs department about why I am 500 miles down the road while being off duty.
     
    bzinger Thanks this.
  8. olddog_newtricks

    olddog_newtricks Light Load Member

    278
    680
    Jun 3, 2018
    0
     
  9. bzinger

    bzinger Road Train Member

    9,728
    25,718
    Dec 10, 2014
    omaha , ne
    0
    Actually when I had my truck towed my Qualcomm didnt kick me on duty or on the drive line...had it towed about 5 miles .
     
  10. Dave_in_AZ

    Dave_in_AZ Road Train Member

    17,567
    43,105
    May 4, 2015
    0
    I wouldn't care about log department. If it doesn't record, just play by the rules, use your trustee Landstar paper logbook, and have them edit it onto the e log when you get to the shop.

    Email yourself the last 7 days before you try it.
     
    Bumper and bzinger Thank this.
  • Draft saved Draft deleted