Detroit 60 Series Coolant Gauge Issues

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Benzdel, Jun 15, 2024.

  1. Benzdel

    Benzdel Bobtail Member

    1
    0
    Jun 15, 2024
    Vancouver BC
    0
    Hi I have a 2007 Frieghtliner with a 60 series Detroit, my problem was since i bought the truck the coolant Temp gauge never worked. So from my research there are 2 coolant sensors on the passenger side of the engine towards the rear of the engine. So far i have changed both sensors for brand new ones and changed the gauge for a new one, still nothing. the gauge has 12V dc coming from one side, ground at the middle and one signal which i toned out with a toner going all the way to the connector on the coolant sensor. so it seems wiring is okay im not 100% sure though, do both sensors run through the ECM or just one ? and which sensor goes to the gauge the bigger one or slimmer one. my mechanic can seem to figure it out either. if someone has a diagram of what the wires going to the connector are and what the wires going th the gauge are that would be a great help. I bought some wiring diagrams online but they dont show much. if anyone would know where else to check that would be great. or any other troubleshooting tips would be greatly appreciated.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Smellfunny

    Smellfunny Road Train Member

    1,440
    960
    Jan 28, 2012
    South Carolina
    0
    I would hook a diagnostic computer up and see if it reads coolant temp. That way you know which way to go. No reading then toward the sensors. Reading at the ECM then a loss of communication from the ECM to the cab.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.