Eaton ultrashift really slow at take off? First 5 gears

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by mixingconcrete, Apr 19, 2021.

  1. mixingconcrete

    mixingconcrete Bobtail Member

    48
    7
    Apr 14, 2019
    0
    Hello, have a 2016 kenworth t880 with the ultrashift and this thing scary slow the first 5 gears. Trying to get thru an intersection takes forever. Is this normal? It starts out mostly at 2 but sometimes i switch it to 3rd but it still seems very slow. We had it at kenworth dealer and they reset everything to factory spec.
     
    JSanborn103 and Dave_in_AZ Thank this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Magoo1968

    Magoo1968 Light Load Member

    106
    242
    Mar 18, 2021
    St Malo mb
    0
    It is if it’s hooked to a x15 efficiency motor that’s tweaked for fuel mileage.
     
    QuietStorm Thanks this.
  4. mixingconcrete

    mixingconcrete Bobtail Member

    48
    7
    Apr 14, 2019
    0

    No its a paccar mx13 engine. We have about 6 trucks with the allison and those shift fast and they get off the line quick. This ultrashift is just horrible.
     
  5. Magoo1968

    Magoo1968 Light Load Member

    106
    242
    Mar 18, 2021
    St Malo mb
    0
    Not sure if the paccar has the acceleration pre second feature like the x15. But I know transx spec trucks accelerated ridiculously slow until dealer was told he’s getting them back then they tweaked ecm and it was okay
     
    Dave_in_AZ Thanks this.
  6. mixingconcrete

    mixingconcrete Bobtail Member

    48
    7
    Apr 14, 2019
    0
    It feels as if the engine accelerates pretty fast and strong but its the gears that feel super slow. Either it needs to skip gears or the ratio feels like its in crawler gears.
     
  7. TheLoadOut

    TheLoadOut Heavy Load Member

    731
    2,566
    Nov 6, 2019
    0
    Try it with the engine brake on, it should shift a little faster.
     
  8. Goodysnap

    Goodysnap Road Train Member

    2,237
    5,032
    Jul 12, 2017
    0
    You need to change the vocational shift response in configuration. You will most likely find it set to smooth. Change it to Fast.
     
    Magoo1968, spsauerland and Dave_in_AZ Thank this.
  9. spsauerland

    spsauerland Road Train Member

    3,616
    9,243
    May 31, 2010
    West Harrison, In
    0
    I know on one of our MX powered trucks, I you have newer transmission software it can be changed to an "aggresive performance" in the configuration. Helped for take off with the 8LL and 10 speed Ultrashift's we have. Still not as quick and smooth as the 18 speed Ultrashift we have and never going to replace an Allison rapid acceleration.
     
  10. mixingconcrete

    mixingconcrete Bobtail Member

    48
    7
    Apr 14, 2019
    0
    ill try that and see if it does anything at slow speeds
     
  11. mixingconcrete

    mixingconcrete Bobtail Member

    48
    7
    Apr 14, 2019
    0
    Dealer said that it was set to fast shifts and then changed it to factory specs and i honestly couldnt tell a difference. Both super slow. I always have traffic behind me stacked up because of how slow the ultrashift transmission is
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted