Electrical Problems

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Fulgore, Mar 3, 2021.

  1. Fulgore

    Fulgore Bobtail Member

    5
    0
    Jan 26, 2020
    0
    Hi everyone! Im having troubles with my 2009 freightliner century 14L 60 series. Im having intermittent shut down when I hit the throttle, put cruise control or activate engine brake. engine never goes completely off, its just suddenly cut out. when that happens rpm gauge goes down and then goes back to normal rpms. I repeat is too fast. When engine is cool that happen when you hit the gas, then after engine gets hot that happen after running over 35mph. Its a really strange thing. An important information: This issue NEVER shows codes or check engine light. Thanks for help guys.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. 6cuda6

    6cuda6 Light Load Member

    236
    164
    Oct 9, 2020
    0
    Sounds like you may have a loose or corroded connection someplace as a throttle pedal potentiometer would usually throw a code......your going to need a set of schematics and a digital volt meter to work at this effectively. If you dont have that you can start at the throttle pedal and follow the wires till you get to a connector, open it up, look at it and if it looks good keep following the wires repeating the inspection process for all the wires that are related. Or you can take it to a reputable shop but you will pay for ever hour diagnosed which can add up very fast.
     
  4. Fulgore

    Fulgore Bobtail Member

    5
    0
    Jan 26, 2020
    0
    Thanks for reply. Somebody told me that could be timing issue or crankshaft broken tooth that cause loosing signal of TRS but i don't think so. Im sure is an electrical problem. I'm going to check TPS.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted