Engine won't start Detroit 60 series 12.7 2000 Freightliner

Discussion in 'Trucks [ Eighteen Wheelers ]' started by eric19067, Nov 27, 2015.

  1. eric19067

    eric19067 Bobtail Member

    5
    2
    Aug 10, 2012
    0
    Hi, I have a 2000 Freightliner Century with a Detroit 60 series 12.7 liter motor. The truck will not start after parking at a rest area. The last thing that happened was the idle started misfiring I revived it up and it still missed up high. The tach from from the normal 2200 to 2350 bouncing around. I shut off the motor and then when I turn the ignition on the opt idle light flashes. The solinod going to the radiator fan clutch even releases air with the same beat as the opt idle flashing. I tried wd 40 to start it right near the intake. I just that the drive turns the fuel pump. I turned the fuel pump and it rises fuel in the clear dome. Disconnected the batteries and reconnected. All this right now here at a rest area. Thanks
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Bogi

    Bogi Light Load Member

    114
    31
    Jul 15, 2013
    Elk Grove Village, IL
    0
    we need to carry backup ECU under the bed
    don't pay more than $500 for used one
     
  4. baha

    baha Road Train Member

    4,137
    2,826
    Jul 25, 2013
    ga
    0
    Turn on key and flip on crus. con. switch an hold up acc. cruz. switch and count flashes on red and yellow light on dash then give out the num. code that is flashing,Change fuel filter!
     
  5. eric19067

    eric19067 Bobtail Member

    5
    2
    Aug 10, 2012
    0
    Hey guys! A good looking solo RV lady offered to help and just made me dinner. That was very kind of her. I tried the code switch method and it does work on this truck. I did the proper method and nothing.
     
    Last edited: Nov 28, 2015
  6. eric19067

    eric19067 Bobtail Member

    5
    2
    Aug 10, 2012
    0
    It does not work I meant. When the the ignition is turned on, the opt idle light flashes. The bunk idle engine control box for adjusting idle temp shutdown etc blinks on and off too. They both flash. As of now I'm thinking the ecu is bad. I'm running out of ideas. I'm reading in a service manual that to disable idle shut down, it says turn off cruise control, push in tractor air knob or press clutch and it will disable. I tried pulling the ecu 10 amp fuse under the passenger side panel. The opt idle light stops flashing after I pull the ecu fuse, starts flashing when it's plugged back in.
     
    Last edited: Nov 28, 2015
  7. eric19067

    eric19067 Bobtail Member

    5
    2
    Aug 10, 2012
    0
    I replaced the ecu and the truck runs now. The reman ecu had idle shutdown after 10 minutes. I went back a day later and had that disabled. The Detroit motor makes to much noise at 1650 torque and feels to like its too much. I had the computer set at 430/470 1550. It's running more quiet and fuel consumption is 3 bars better on average according to the meter on the dash.

    Thanks
     
  8. heavyhaulerss

    heavyhaulerss Road Train Member

    3,715
    2,025
    Dec 23, 2009
    AL/TN BORDER
    0
    and where do WE find good used ones for 500.00 or lower?
     
  9. BCO532335

    BCO532335 Light Load Member

    54
    23
    Mar 5, 2012
    wesley chapel,fl
    0
  10. heavyhaulerss

    heavyhaulerss Road Train Member

    3,715
    2,025
    Dec 23, 2009
    AL/TN BORDER
    0
    yeah I have looked on there every so often hard to find at that price though.
     
  11. BCO532335

    BCO532335 Light Load Member

    54
    23
    Mar 5, 2012
    wesley chapel,fl
    0
    Same here.
    I got one for $450 a couple years ago.Keep looking.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted