epg1 problem

Discussion in 'Trucks [ Eighteen Wheelers ]' started by jaielv, Oct 10, 2012.

  1. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    has anybody had this issue mid 128 ppid 124 fmi 5. I know is the epg1 just can find what's the short replace the avu check the fuses, relays and nothing.any one with similar problem please advice thank u
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Pablo-UA

    Pablo-UA Road Train Member

    7,604
    1,632
    Oct 11, 2010
    Borispol, Ukraine
    0
    Do you have Volvo? what year?
     
  4. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    Volvo vnl 670 465 d12d Volvo engine 2004
     
  5. Pablo-UA

    Pablo-UA Road Train Member

    7,604
    1,632
    Oct 11, 2010
    Borispol, Ukraine
    0
    it is solenoid electrical fault

    may be corroded connector, may be wiring, may be bad solenoid

    check all this stuff
     
  6. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    What solenoid the one under the valve cover.because I lost the veb,engine brake
     
  7. Pablo-UA

    Pablo-UA Road Train Member

    7,604
    1,632
    Oct 11, 2010
    Borispol, Ukraine
    0
    the solenoid under the valve cover is VEB (jakes) solenoid.

    EPG silenoid is mounted on cyl blosk, driver's side near bellhousing, it is on frame rail level.

    Solenoid may be damaged with oil, that leaks to wiring harness throught the rubber grommet in point were wires come under valve cover.
     
    mno Thanks this.
  8. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    the one on the frame with an air line going to one side and a 4 or 5 electrical plug on the driver side left.because I replace the one next to starter avu or air vale is that the one or is there also a solenoid next to the air valve.this problem started when I was replacing the starter and hot cable touch the frame.it burn a couple fuses ecm#81 and #15 radio try to see if there was any relay or fuse for epg solenoid and could not find any .I replace all my relays to see if it will solve it and nothing.
     
  9. Pablo-UA

    Pablo-UA Road Train Member

    7,604
    1,632
    Oct 11, 2010
    Borispol, Ukraine
    0
    ouh..... can you find EPG? it is on turbo. Look where air line from EPG goes (8mm) and you find solenoid
     
  10. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    ok is the on connected to turbo with one clamp?I thought that was the engine brake.I see the hose from air valve connects to that is that the solenoid or engine brake?
     
  11. jaielv

    jaielv Light Load Member

    62
    11
    Dec 30, 2010
    joliet,il
    0
    [​IMG] Is this the solenoid?this is the part I replace
     

    Attached Files:

  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted