Good ole grinding 55mph and up from what seems to be the transmission...

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Bigmike1977d16, Jul 10, 2021.

  1. Bigmike1977d16

    Bigmike1977d16 Bobtail Member

    27
    39
    Aug 22, 2017
    0
    Hello everyone, maybe I can get some information.
    2008 Peterbilt
    Isx
    13 speed

    Bought my truck, drove it home had a grinding sound after 50-55mph in 12 and 13th

    Took it to a shop changed the drive shaft and all the shocks.. had less noise. Or I thought it did.

    Did 4200 miles the grinding rattling vibration was too much. Took it to a shop.

    Had the transmission changed with a rebuild. noise stopped for about 1300 miles then slowly came back. Noticed the rear seal started leaking.

    Put another 6000 miles on it and it's back full force. Typical push the accelerator it goes away, coast it comes back. In 12th and 13th.

    Took it back to the shop had a full alignment done ride hight adjustment done, driveshafts all removed checked diffs re angled, center bearing angle checked. No difference. Just put another 2200 miles on it.

    So at this point I have no clue what to go after next. Any suggestions would be much appreciated. Thanks in advance.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. John E.

    John E. Light Load Member

    188
    663
    Apr 4, 2021
    New Brunswick
    0
    There have been times I just had to run the Rig for several thousand miles and eventually the problem shows itself, hopefully before you need a tow.
     
    Bigmike1977d16 Thanks this.
  4. PSM379

    PSM379 Medium Load Member

    371
    1,001
    Apr 19, 2019
    0
    Edit, overlooked ride height adjusted already
     
    Rideandrepair Thanks this.
  5. Rubber duck kw

    Rubber duck kw Road Train Member

    5,131
    14,221
    Dec 9, 2017
    0
    Assuming you had a new clutch put in with the trans.
     
  6. Arctic_fox

    Arctic_fox Heavy Load Member

    716
    1,920
    Sep 16, 2016
    0
    Do you have lockers and/or a power divider on your truck? Sometimes those can lock up a bit and would cause the problems your seeing. Also have them check the balls and barrings and also make sure you look at the carrier barrings. Thats all i can think it would be.
     
    Bigmike1977d16 Thanks this.
  7. Bigmike1977d16

    Bigmike1977d16 Bobtail Member

    27
    39
    Aug 22, 2017
    0

    Yep seems like what I'm forced to do.
     
    John E. Thanks this.
  8. little cat 500

    little cat 500 Road Train Member

    1,646
    728
    Jan 17, 2010
    Abbottstown PA
    0
    my truck did this when the ride height was to low
     
    Rideandrepair and Bigmike1977d16 Thank this.
  9. uncleal13

    uncleal13 Road Train Member

    3,407
    5,251
    Apr 9, 2009
    Humboldt, Sk
    0
    I had the air ride valve cause that.
    Going down the road it would slowly fill up the air bags to maximum. Sometimes took a few days. Made a grinding sound.
    Had it for over a week. Every time I swap trailers I always dump the air. So the last time I didn’t dump the air, pulled out from under the trailer and the suspension stayed up, it didn’t let off air to release the pressure from having the trailer on the truck.
    So I replaced the air suspension valve and never heard the grinding noise again.
     
  10. Bigmike1977d16

    Bigmike1977d16 Bobtail Member

    27
    39
    Aug 22, 2017
    0
    Update and thanks to for all the replies.
    Did a quick 700 miles today adjusted the ride hight myself. Y'all seem to be right it's the leveler valve. First dropped the suspension a bit as I had no idea what the shop did. Kind shifted the grinding noise to higher speeds. Then dropped it a bit more made it just as bad as I started. Then I raised it was smooth till i hit a few good bumps and it came back. Dropped my trailer at the yard raised it some more much less grinding bobtail. It comes and goes.. Monday I'm buying a valve and a new adjustable stick thingy. I'll post results. But it seems to be what's going on..
     
  11. Bigmike1977d16

    Bigmike1977d16 Bobtail Member

    27
    39
    Aug 22, 2017
    0
    Update

    Changed the leveler valve and rod thingy.
    Adjusted the ride hight myself. Did 600 miles no more grinding but I'm.sure I just have to dial it in a bit more. Suspension seemed to be about half an inch to an inch too low. As far as I can tell problem solved. I'll post one more update in a week or 2 if I made anymore corrections or what not

    So anyone googling this problem please start with your ride height adjustment. It's around a 100$ repair that you can do in about 40 minutes.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted