Half a tank blues

Discussion in 'Expediter and Hot Shot Trucking Forum' started by Ellijay, Oct 9, 2014.

  1. Ellijay

    Ellijay Bobtail Member

    39
    9
    Feb 16, 2014
    0
    Anyone with first hand experience with this please speak. 2008 6.7 full delete mild EFI tune (80k since The D and tune. And has been running great since the tune and D now has 255k total. Well this week I done a east to west run and after the 4th fuell filter I come to realize it was doing after a half a tank only,new filter or not. Cutting out,no power and lots of black smoke,the emptier it gets the worse it gets. If I keep it at half a tank or more pulls like a train!! Wth ?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. xsetra

    xsetra Road Train Member

    4,554
    5,723
    Aug 21, 2011
    0
    Maybe your tank vent is plugged.
     
  4. icsheeple

    icsheeple Trailing the Herd

    2,548
    2,547
    Nov 1, 2013
    Kansas City, KS
    0
    Check the vent, do you have a secondary fuel filter?
     
  5. Ellijay

    Ellijay Bobtail Member

    39
    9
    Feb 16, 2014
    0
    No the fuel supply and filters are all stock. Will check the vent out today.
     
  6. StrongArm

    StrongArm Light Load Member

    50
    11
    Apr 2, 2014
    New York, NY
    0
    Bad fuel? Do you have a way to drain the tank? Drain the water separator? Just suggestions, I dont know too much about that motor.
     
  7. Ellijay

    Ellijay Bobtail Member

    39
    9
    Feb 16, 2014
    0
    It started in Knoxville tn and did that all the way to southerner Cali and back,5000 + miles and five filters. I'm about to drop the tank as we speak,iv been told half a dozen times its only pickup tube broken or has a hole in it. I'll know in a hour.
     
    baha Thanks this.
  8. Ridgeline

    Ridgeline Road Train Member

    18,633
    85,400
    Dec 18, 2011
    Michigan
    0
  9. Ellijay

    Ellijay Bobtail Member

    39
    9
    Feb 16, 2014
    0
    Really? ...
     
  10. Ridgeline

    Ridgeline Road Train Member

    18,633
    85,400
    Dec 18, 2011
    Michigan
    0
    Again what was deleted?

    EGR and DPF system??

    I wondered what else was done, like maybe a sump pickup on the tank, better plumbing form the tank to the fuel system?

    Sounds like you got a problem with the fuel pickup in the tank.
     
  11. Ellijay

    Ellijay Bobtail Member

    39
    9
    Feb 16, 2014
    0
    i said full delete from the very beginning(you even highlighted it for me). But the fuel supply is all factory. it was a bad fuel cap believe it or not,was about to drop the tank when I read the cap vent could be stopped up so I took it off drove to parts store and has been running great since.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted