HELP! 2001 Volvo dayCab shorting out somewhere?

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by JDO, Aug 20, 2021.

  1. JDO

    JDO Bobtail Member

    7
    1
    Aug 20, 2021
    0
    New to me Volvo truck with a Cummins ISM 370 and Eaton fuller 8 speed.

    All the sudden gauges started going crazy
    Ac clutch going in an out
    Fan clutch in an out
    Just crazyness

    I’ve checked out everything thing simple, looking for shorts etc. I’m new to working on big rigs so I’m learning (but work on my 06 Dodge common rail pretty often).

    Each battery shows nearly 13 volts and there only a few months old. The truck cranks fast and starts right up.

    But the volt gauge on the dash only is showing around 10, going up or down. Lights get dimmer, then brighter, heater fan barely will blow (not enough voltage).
    Like something is drawing way to much power, or something in hindering it.
    Wondering where to go from here
    Thanks!
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,625
    1,509
    Jun 14, 2009
    romulus,mi
    0
    Under hood on driver side firewall there is plastic manifold that a bunch of air lines pass thru to inside the cab. In the lower right hand corner of that manifold you will see power and ground cables bolted on studs. Check voltage and ground at those studs.
     
    spsauerland Thanks this.
  4. JDO

    JDO Bobtail Member

    7
    1
    Aug 20, 2021
    0
    E0001D14-4641-49B2-956F-831CE4069455.jpeg Ok, so I found the post at the firewall, 13 at it.
    Then checked under the dash at the fuse panel, 13 at the first post, then 13 on the other 2 when I turn on the key.
     

    Attached Files:

  5. CammedZ71

    CammedZ71 Bobtail Member

    3
    0
    Aug 20, 2021
    0
    Does it go nuts when you’re sitting still or moving?
     
  6. JDO

    JDO Bobtail Member

    7
    1
    Aug 20, 2021
    0
  7. JDO

    JDO Bobtail Member

    7
    1
    Aug 20, 2021
    0
    Wanted to post back the found problem. The ground terminal on the firewall (in the first picture) wasn’t getting good connection. Cleaned it and volt gauge now showed 13 volts with the heater fan on and everything is back to normal. Thanks for the interest guys
     
    Socal Xpress Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted