Help!! Maxforce 10 reading too much icp pressure at full throttle under a load

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by bobg0710, Jun 28, 2022.

  1. bobg0710

    bobg0710 Bobtail Member

    2
    0
    Jun 28, 2022
    0
    Hey everyone. I am new here but have been working on trucks for 28 years. I have one that has me a bit stumped. I have a 2012 Maxforce 10 in one of our fleet vehicles that had a intermittent hard start. The ICP desired and actual pressure seemed to be in correlation and would read a max pressure of roughly 4200 psi when hot under full throttle load, The IPR had a questionable connector end so I threw a new IPR valve that I had sitting on the shelf. The truck seemed better but would still start hard occasionally so I pressure tested the high pressure oil system and found a 1" hairline crack in the rail that was leaking. I installed a new rail and reassembled and tested with no leaks. Now when I test drive and hold the throttle down from a start, the icp pressure maxes at 4917psi and the check engine light flashes and the scanner flashes subsystem fault in the pressure reading line then the engine derates and the readings pop back up on the scanner. The code comes up as undefined spn 164 fmi 2. As soon as the icp reaches 4917 psi for about 2 seconds it does the same thing every time. When it hits actual 4917psi, the desired is asking for roughly 4600 psi and the IPR is commanding 98%, and ICP voltage is 4.9v, The truck runs normal with no check engine light until it is under hard acceleration and icp hits the 4917. I did realize that the IPR valve I installed was for a DT466 so I bought another International one for the maxforce in case the parameters were different .even though it had no problems or check engine light until I changed the rail.so I am not sure if it had an underlying icp over pressure issue that wasn't detected because of the leak or if it happened during the install of the IPR valves and the new high pressure oil rail.I thought maybe the ECM maybe needed to relearn the icp so I ran the truck for a while but the problem still exists. Any help or advise is appreciated. Thanks.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Inderjit

    Inderjit Medium Load Member

    425
    456
    Sep 17, 2017
    0
    I would question the accuracy of the injection pressure sensor. I usually replace the sensor when the valve cover is off since its a big job to do it later. There is an update on the IPR valve but that should not be causing your problem.
     
    spsauerland Thanks this.
  4. bobg0710

    bobg0710 Bobtail Member

    2
    0
    Jun 28, 2022
    0
    I was wondering that also. but when the truck is off it reads zero and the pressures are in line between desired and actual all the way up past 4000psi.. when its reading 4917 psi the IPR in in the 90's percentile range and desired is reading 4500-4600 ICP voltage 4.9. I am not sure. No other codes other than spn 164 fmi 2 which is active every time it hits 4917 psi for a couple seconds then it derates for another couple seconds and then power comes back until it goes active again.
     
  5. Inderjit

    Inderjit Medium Load Member

    425
    456
    Sep 17, 2017
    0
    It would be a pain to plumb in a mechanical gauge but it could be done.
     
    BoxCarKidd Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted