Kenworth 2010 T660 Foglights

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Ullihundi, Jan 13, 2018.

  1. Ullihundi

    Ullihundi Bobtail Member

    I've been going in circles on this. The factory fog lights worked on day and not the next. No power, checked all fuses (behind clutch and in engine compartment). No voltage at fog lights. I called KW and was told fuse is location L9 and P9, my panel ends at J. Any ideas?
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. spsauerland

    spsauerland Road Train Member

    3,853
    9,847
    May 31, 2010
    West Harrison, In
    0
    Those are fuse locations in chasis load center. Under hood, drivers side fuse panel.
     
  4. Goodysnap

    Goodysnap Road Train Member

    2,634
    6,016
    Jul 12, 2017
    0
    Make sure your checking with headlights on. Most of the newer paccar stuff headlights must be on for foglights to work.
     
  5. Pedigreed Bulldog

    Pedigreed Bulldog Road Train Member

    7,744
    14,392
    May 7, 2011
    0
    Unplug 'em. Remove 'em. Problem solved. Ought to be illegal to run down the road with those stupid things on, anyway...almost always misaligned and blinding the piss out of everyone around them.
     
  6. bbechtel16

    bbechtel16 Medium Load Member

    570
    68
    Oct 13, 2009
    PA
    0
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted