Lost all power to sleeper and interior lights 2017 579.

Discussion in 'Peterbilt Forum' started by Arctic_fox, Jan 3, 2022.

  1. Arctic_fox

    Arctic_fox Road Train Member

    1,244
    3,797
    Sep 16, 2016
    0
    So i left my truck and apu off for about an hour and went inside to get in my shower. Came out and none of my sleeper lights work. Truck starts fine and shows 14V though was at 12.2 when i first started it, it had no LVD message however. I let it idle for about an hour thinking the voltage was low anyway then went to check my fuses and nada. All the fuses in the bunk colum look fine and i checked the sleeper fuse under the dash and they appear fine.

    Any idea whats going on? My only solution is bad batterys even though they are less then a year old.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. LoSt_AgAiN

    LoSt_AgAiN Heavy Load Member

    748
    3,684
    Sep 7, 2018
    0
    Do you have a battery cutoff switch?
     
  4. Arctic_fox

    Arctic_fox Road Train Member

    1,244
    3,797
    Sep 16, 2016
    0
    Not that i can find. Tried pulling the terminals and cleaning them now as well.
     
    LoSt_AgAiN Thanks this.
  5. North Pole Nightmare

    North Pole Nightmare Light Load Member

    136
    214
    Dec 15, 2021
    0
    Does the apu work?If not reset the gfi plug in on it.
     
  6. Arctic_fox

    Arctic_fox Road Train Member

    1,244
    3,797
    Sep 16, 2016
    0
    APU and espar work fine. Only things that dont are lights, 12 volt sockets, and fridge.
     
  7. IH Truck Guy

    IH Truck Guy Road Train Member

    2,401
    26,453
    Mar 2, 2008
    Purgatory
    0
    If your truck has a low voltage cut-off,the first thing it kills is the bunk area.
    Starting the truck would've corrected that.
    So either you have a bad cut-off relay or a different problem
     
  8. North Pole Nightmare

    North Pole Nightmare Light Load Member

    136
    214
    Dec 15, 2021
    0
    Lost all power to sleeper after LVD - 2016 579
     
  9. North Pole Nightmare

    North Pole Nightmare Light Load Member

    136
    214
    Dec 15, 2021
    0
    I found this earlier thread,might be your problem,fuse
     
  10. Arctic_fox

    Arctic_fox Road Train Member

    1,244
    3,797
    Sep 16, 2016
    0
    Yup that didnt fix it. I pulled and replaced every single fuse with fresh just to be sure and am now traceing the wires. Im out of ideas lol
     
  11. Siinman

    Siinman Road Train Member

    1,527
    2,637
    Mar 5, 2017
    Kansas City, MO.
    0
    That sucks man. One more bull sheet thing to deal with on that truck.
     
    Catmando Thanks this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted