Low Oil Pressure Warning - Detroit Diesel engine series 60

Discussion in 'Trucks [ Eighteen Wheelers ]' started by sameehr, Feb 2, 2012.

  1. sameehr

    sameehr Bobtail Member

    1
    0
    Feb 2, 2012
    holiday,fl
    0
    I have 1999 freightliner century c120 DD engine series 60 I had the warning low oil pressure come on took it to the mechanic he said the oil pump is fine and the pressure is good the gauge shows good pressure from 45-50 psi at first when I start the truck the warning would come on and when the water temp reached 150 degrees and I shut the engine and start back it goes away now the #### thing will not shut off even when the water temp reaches 155 and above, it goes away for a few seconds when i hit the ( trip,leg,temp) buttons any of the buttons and then it comes back, any ideas please:biggrin_2552::biggrin_2552:
     
  2. Smellfunny

    Smellfunny Heavy Load Member

    846
    320
    Jan 28, 2012
    South Carolina
    0
    Probably need to replace the low oil pressure sensor. You can have someone scan the truck and it should tell you. Sensor runs around 75 bucks I think.
     
  3. Dino1968

    Dino1968 Light Load Member

    If your guage in the dash show's OK pressure, it's more than likely the ECM sensor. It's located on driver's side rear. about straight up from starter. It's a bit tough to get to. Fuel lines and air lines in the way possibly. Be sure to unplug the wiring from the sensor b4 you start to turn it. Trying to remember what size socket it takes, ahhhh it's been too long LOL. Use the new sensor to see what it takes to fit the old one.
     
  4. Smellfunny

    Smellfunny Heavy Load Member

    846
    320
    Jan 28, 2012
    South Carolina
    0
  • Draft saved Draft deleted