Mack cxn613, oil pressure drops when warmed up.

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by Shahid123, Jan 15, 2021.

  1. Shahid123

    Shahid123 Bobtail Member

    4
    0
    Jul 8, 2020
    0
    I been having problem with the oil pressure on this truck. Oil pressure is where it should be when cold but as it gets hot it keeps dropping. It doesn't move much even if i push throttle to the floor when hot. Never had a dash sign or shut off. Any help would be appreciated thanks. Original mack e7 engine 380hp.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Brettj3876

    Brettj3876 Road Train Member

    6,252
    23,686
    Nov 18, 2014
    On thin ice
    0
    What's the psi running hot and cold? Both of ours run 60 psi at highway speed and 30 idle hot
     
  4. Shahid123

    Shahid123 Bobtail Member

    4
    0
    Jul 8, 2020
    0
    It use to run around 15 idle when hot and would drive normal but recently drops to just below 10 when hot idle and while running just gets to 20, cold idle is close to 60psi. I was told 10-30 is normal psi for this engine when hot. Dealer mechanic told me it could be the pump? Thanks for quick reply.
     
  5. Brettj3876

    Brettj3876 Road Train Member

    6,252
    23,686
    Nov 18, 2014
    On thin ice
    0
    I'll go look at the book in a sec but I believe hot idle at 650 is supposed to be 15-30 and 45-60 on the road I think. I wouldn't run that until you fig out the issue. Not that big of a deal to drop the pan and check to see if the pump is within spec.

    10psi is really low for hot idle. If my oil temp is up around 190 it goes down to 25 but shoots right back to 30 after a few min to cool down idling. How many miles on her. Ours has 100k on inframe and the other 500k
     
  6. BoxCarKidd

    BoxCarKidd Road Train Member

    3,137
    4,283
    Aug 26, 2014
    0
    I have 3 of those getting fuel in the oil.
    #1 had pipe plug in the front block fuel galley leaking. Looked like the factory dry loctite had desolved.
    The other plug next to it was also loose.
    #2 and 3 had a leaking fuel supply pump.
    You cannot see anything about those from the bottom other the fuel leak from the front. Is it over full of oil?
    One of the three was out of state like that. We had the oil and filters changed. Pressure came back up and drove it home.
    If you thank and or test it has fuel in oil remove the fuel supply pump first. Hook the lines and all back up and build pressure with the hand pump. It is common for the shaft seal to leak and you can see that.
     
    Brettj3876 Thanks this.
  7. Shahid123

    Shahid123 Bobtail Member

    4
    0
    Jul 8, 2020
    0
    Has 420k km's on it. I did have the injector o rings changed at the dealer not too long ago because one leaked and it was mixing diesel with oil. Thanks for your help.
     
  8. Idahojoel

    Idahojoel Light Load Member

    61
    43
    Jan 17, 2018
    Phoenix Arizona
    0
    Mechanical pressure gauge ? Dash gauges lie all the time
     
  9. Shahid123

    Shahid123 Bobtail Member

    4
    0
    Jul 8, 2020
    0
    Yes they put mechanical gauge at dealer it was reading same as dash. I changed the pressure sensor and same.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted