No heat in 2015 Peterbilt 579

Discussion in 'Peterbilt Forum' started by calvinbabb, Jan 8, 2022.

  1. calvinbabb

    calvinbabb Bobtail Member

    40
    30
    Apr 28, 2016
    Trenton, Fl.
    0
    No heat in 2015 Peterbilt 579. I turn the deep frost on to max and it will cook you out of the truck. When I turn it to just regular defrost I get nothing but cold air. The actuators appear to be working to opening the doors to change from foot to defrost to chess vents. But nothing will come out other than cold air. Just don’t understand why I have heat on max defrost only.


    If this post sounds funny or looks funny in the spelling, I’m using voice to text. Sorry
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Arctic_fox

    Arctic_fox Road Train Member

    1,257
    3,888
    Sep 16, 2016
    0
    Likely a bad actuator in the system. That said rule out a blown fuse first using a tester. Then rule out that one of your taps is closed on the heater core. Easy to check and cheap.

    If there is no blown fuse and the taps are open then you need to have a dealer run a test on the system, i think its called an esa? It will tell you exactly whats wrong and may just be you have the old software still and a quick update will fix it.
     
  4. calvinbabb

    calvinbabb Bobtail Member

    40
    30
    Apr 28, 2016
    Trenton, Fl.
    0
  5. calvinbabb

    calvinbabb Bobtail Member

    40
    30
    Apr 28, 2016
    Trenton, Fl.
    0
    I have all positions get air when their prospective selection is made on the climate control but is cold. So those doors are working. I get cold air on defrost normal. But if I hit defrost max it’s hot. When I turn off the max, I can feel the warm air come from any vent just briefly until that air cools again. Almost like the blend door is closing on anything other than max defrost.
     

    Attached Files:

  6. Arctic_fox

    Arctic_fox Road Train Member

    1,257
    3,888
    Sep 16, 2016
    0
    Hummmm check the heater core lines. Are they warm to the touch? Also check your coolant level.

    Also could still be one of the actuators sticking but the one doe the defrost opening or being forced open by the warm airflow.
     

    Attached Files:

  7. calvinbabb

    calvinbabb Bobtail Member

    40
    30
    Apr 28, 2016
    Trenton, Fl.
    0
    Lines going to coil are hot. Both. Coolant full. I hate going to the stealer but looks like I’m gonna have to
     
  8. Arctic_fox

    Arctic_fox Road Train Member

    1,257
    3,888
    Sep 16, 2016
    0
    Yep sadly i think so as well. If the lines are hot, coolant is full, fuses are all good and there is nothing obviously broken or leaking then its either a deeper electrical problem, a bad actuator, or if your really lucky a bad control switch. The max defrost at least on my 17 579 is on a diffrent wire and circut then the control knob.
     
  9. FLHT

    FLHT Medium Load Member

    476
    468
    Aug 2, 2014
    0
    Fresh air / recycle air door not shutting ?
     
  10. calvinbabb

    calvinbabb Bobtail Member

    40
    30
    Apr 28, 2016
    Trenton, Fl.
    0
    It operates fine. Can definitely tell a big difference from open to close
     
  11. GreenPete359

    GreenPete359 Road Train Member

    1,917
    3,303
    Oct 21, 2017
    Driving my recliner
    0
    Check your cabin air filter & look at the heater core itself. Make sure the fins are clear of any gunk or debris
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted