No power. At a loss here. Losing hair.

Discussion in 'Volvo Forum' started by Amram, Mar 15, 2018.

  1. Amram

    Amram Medium Load Member

    448
    232
    Feb 4, 2017
    0
    Truck has lost all its balls. 6500lb loads and it is struggling to pull them. No low end power. Turbo boosting up to 45 psi on small hills and truck still falling on its face. Currently have check engine light for 1127 fmi 16. I have replaced the intake manifold pressure sensor, turbo speed sensor, egr cooler, have had the egr valve tested to make sure it is working. I have had the truck checked for boost leaks. I have the revised venturi pipe with new delta P sensor. Truck is not having hard start issues. Have replaced fuel filters. Had fuel tanks checked. Truck has no sack no more. Ready to burn it.
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Justrucking2

    Justrucking2 Road Train Member

    3,211
    4,258
    Sep 12, 2017
    Plymouth MI
    0
    What year? Motor? If it has SCR have you removed and inspected the box for cracks and or leaks?
     
  4. Amram

    Amram Medium Load Member

    448
    232
    Feb 4, 2017
    0
    2013 d13. Scr is deleted. Was causing too much downtime. After 600k miles it was in the shop every few weeks for another sensor or some stupid garbage.
     
  5. Justrucking2

    Justrucking2 Road Train Member

    3,211
    4,258
    Sep 12, 2017
    Plymouth MI
    0
    Cummins? If so, do you know about the fuel pump? And when they deleted, did the remove and weld that SCR box up?
     
  6. Amram

    Amram Medium Load Member

    448
    232
    Feb 4, 2017
    0
    Volvo engine. D13. I did the actual delete install. Kit is from OTR performance. I took dpf out. Drilled holes in the filter. Put new gaskets in the assembly. Reinstalled. Bypassed catalyst box with an elbow pipe and some flex. Took box completely off. Truck looks like an epa 07 setup.
     
  7. Justrucking2

    Justrucking2 Road Train Member

    3,211
    4,258
    Sep 12, 2017
    Plymouth MI
    0
    Well, the cans DPF DOC need to be hollowed out to the skin of the can. As far as the programming, no clue what those guys do, but I doubt it is good. Do you have a pyrometer gauge installed to measure exhaust gas temps? Sounds like your motor is cooking itself. You said the CEL is on, are their any codes showing? Or just the idiot light on the dash?
     
  8. Justrucking2

    Justrucking2 Road Train Member

    3,211
    4,258
    Sep 12, 2017
    Plymouth MI
    0
    Is the EGR valve opened or closed, do you know?
     
  9. Amram

    Amram Medium Load Member

    448
    232
    Feb 4, 2017
    0
  10. Amram

    Amram Medium Load Member

    448
    232
    Feb 4, 2017
    0
    Egr system is functioning. I do not have any codes for egr flow rate anymore.
     
    homeskillet Thanks this.
  11. Justrucking2

    Justrucking2 Road Train Member

    3,211
    4,258
    Sep 12, 2017
    Plymouth MI
    0
    EGR is working, should be closed, not good. I would call a dealer right now and ask them what that code means if you haven't already. Sounds like a bad delete. I would head over to Rawze.com, ask for an invite, there are mechanics/programmers over there that can better help you. Sounds serious to me.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted