Of the mechanics. Oil pressure above 100 psi!!

Discussion in 'Ask An Owner Operator' started by Xenergiserx, Jun 7, 2021.

  1. Xenergiserx

    Xenergiserx Bobtail Member

    41
    18
    Feb 2, 2021
    0
    Truck was running fine. I When to do my oil change I put Mobil oil. I ran 8 miles and the oil pressure when crazy to above 100 psi. What could be wrong .

    im on the side of the road

    cummin isx15
    519000
     

    Attached Files:

  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. blairandgretchen

    blairandgretchen Road Train Member

    9,403
    41,569
    Dec 9, 2011
    South west Missouri
    0
    Pegged out!

    I would check the guage with an alternative scan device. Sender/guage fault elimination.
     
  4. Xenergiserx

    Xenergiserx Bobtail Member

    41
    18
    Feb 2, 2021
    0
    I called the oil tech people they came to the rescue. The oil filte was defective. He replaced it and I was on my way.
     
  5. AModelCat

    AModelCat Road Train Member

    21,927
    101,242
    Jul 7, 2015
    Canuckistan
    0
    International truck?

    I'd be leery of the oil filter being the cause if it is. International's gauges go to the 6 o'clock position when there's a fault in the circuit. Might have been a glitch or you might have a wiring issue developing.
     
  6. Xenergiserx

    Xenergiserx Bobtail Member

    41
    18
    Feb 2, 2021
    0
    Yeah international are not good on the electricals . But the truck has never given oil pressure problems and it happens 5 mins after the oil change. Tech said sometime they come defective from factory. And they have no way to check it. Truck ran fine after filter change
     
  7. blairandgretchen

    blairandgretchen Road Train Member

    9,403
    41,569
    Dec 9, 2011
    South west Missouri
    0
    Wow. Defective oil filter?
     
    God prefers Diesels Thanks this.
  8. SmallPackage

    SmallPackage Road Train Member

    2,469
    6,779
    Dec 20, 2019
    Marion Texas
    0
    Don’t know how the oiling system works on the x15 but if it was an N series and pressure raises like that it could mean the regulator valve stuck open in oil cooler and is allowing full oil pump pressure out through the cooler and into the galleys.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted