Peterbilt with ISX15 starting issues

Discussion in 'Peterbilt Forum' started by BDRyan92, Feb 25, 2018.

  1. BDRyan92

    BDRyan92 Bobtail Member

    9
    16
    Sep 6, 2017
    0
    I’ve looked everywhere with no answer. So I have a 386 Pete with the isx15 Cummins. It starts fairly slow most of the time. Like the battery’s are weak. Then it got to where it would just click but you can feel the starter teeth engage but it’s like something is killing the power to the starter before it starts spinning the engine. So I’ve replaced the batteries and the ones I pulled out were actually new. All the battery cables look new. I replaced the starter. So apparently whoever had the truck was having the same issues and tried to fix it with cables and batteries but didn’t. The day we put a new starter on it it fired up super fast then the next day it was slow again. If I start it everyday and run it then it’s fine. Still kinda slow. But if I leave it over the weekend or for a few days it just clicks. But I can grab two screw drivers and cross out the starter and it will fire right up every time. It’s a 2012 model so it does not have the solenoid on the firewall. Thanks and any info will be appreciated
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Mrfister11

    Mrfister11 Bobtail Member

    6
    2
    Feb 2, 2018
    0
    You could get a relay and and have the wire that's on the solenoid now control the relay to engage solenoid on starter. Run power to relay straight from a 12v source that's straight to battery. Ground one side of control of solenoid. The other side of control goes to original wire going to starter. And the output of relay going down to starter. Now the relay will carry the load and not what is carrying it now
     
    HopeOverMope Thanks this.
  4. beemergary

    beemergary Light Load Member

    228
    112
    Apr 11, 2014
    0
    I bought a battery analyzer that reads the cranking power. Best $29.00 I ever spent. Would have told you if your batteries were weak before spending $$$
     
  5. Elrojo10

    Elrojo10 Bobtail Member

    2
    0
    Sep 14, 2017
    0
    I have the exact same problem and ive done the same changed starter and batteries and it still does the same i have a 2013 peterbilt with isx 15 cummins!!!
     
  6. Watsonrw

    Watsonrw Bobtail Member

    1
    0
    Jul 30, 2021
    0
    Any update on this issue
     
  7. Nss

    Nss Light Load Member

    54
    26
    Jul 5, 2021
    0
    There is a row of relays behind speedo/tach in a block, check there.
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted