PLEASE HELP - My automatic transmission truck wont go into gear

Discussion in 'Peterbilt Forum' started by sprechnd, Apr 5, 2014.

  1. Infidelity

    Infidelity Bobtail Member

    1
    0
    Mar 26, 2020
    0
    My 2009 kenilworth will not start.It has a EATON 18 automatic with a c13 cat
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,739
    1,676
    Jun 14, 2009
    romulus,mi
    0
  4. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  5. 7seriestv

    7seriestv Light Load Member

    229
    144
    Jan 28, 2016
    0
    Did you turn it off in gear? Disconnect the battery cables about 15 minutes so the transmission can reset and try it again
     
    2013Maxx Thanks this.
  6. Prostar 888

    Prostar 888 Bobtail Member

    1
    0
    Aug 13, 2021
    0
    Sir i have international prostar 09 cummins isx its flashing f and N gen trans fault wont crank,i have clutch pedal on my truck I'm suspecting its the clutch but im not shure why is not cranking if you have any experience with this please let me know god bless you and thank you for your time.
     
  7. QUALITYTRUCK

    QUALITYTRUCK Road Train Member

    1,739
    1,676
    Jun 14, 2009
    romulus,mi
    0
    "F" indicates that there is a transmisson fault active in the TCM. Could be any number of things faulting which in turn will not let engine start. Need to plug in with Eaton service ranger software to find solution.
     
  8. Khurramamna

    Khurramamna Bobtail Member

    1
    0
    Sep 4, 2021
    0
    2017 Kenworth t680 cummins isx having a humming noise coming fro driver floor
     
  9. Pete Bilt

    Pete Bilt Bobtail Member

    1
    0
    Sep 14, 2021
    0
  10. AdriaanNam

    AdriaanNam Bobtail Member

    1
    0
    Feb 11, 2022
    0
    I have a eaton transmission that keeps on staying in N and then later flashes N,F if you select drive it goes into gear but then immediately goes back to N could this be a voltage problem or is ECU broken
     
  11. Todd727

    Todd727 Light Load Member

    254
    519
    Jun 7, 2021
    0
    Had a similar issue on an Allison. New alternator fixed it.
     
  12. Chris337

    Chris337 Bobtail Member

    1
    0
    Mar 8, 2022
    0
    What was the problem if u don’t mind me asking bc mine has been doing that for the last few months every blue moon
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted