1. teamscanada

    teamscanada Bobtail Member

    10
    1
    Jul 21, 2021
    0
    I have a Paccar mx13 and I have lost power

    when I start off I step on it and hold it done my manafold pressure goes to 18 and sit for 4 to 5 seconds and then it goes to 28 ….sometime it stays at 18

    when I get to a hill I lose power and it’s at 18 …again after so many seconds it mite pop up to 28 psi …it’s sound like it derating but no check engine light and when I hit 8 grade hill I’m down to 20 km for speed

    can someone help me why

    I clean the dpf filter and still an problem …I replace fuel filter …what can I find
     
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Nss

    Nss Light Load Member

    51
    25
    Jul 5, 2021
    0
    Did you check boost sendor for being plugged?
     
  4. Arctic_fox

    Arctic_fox Heavy Load Member

    742
    1,971
    Sep 16, 2016
    0
    Might be a bad turbo. More likely the tube going into the egr got clogged up. Which is also a good indicator your EGR is clogged and may need a clean.
     
  5. teamscanada

    teamscanada Bobtail Member

    10
    1
    Jul 21, 2021
    0
    Why the turbo jump from 18 to 28 if bad sensor
     
  6. teamscanada

    teamscanada Bobtail Member

    10
    1
    Jul 21, 2021
    0
     
  7. Goodysnap

    Goodysnap Road Train Member

    2,441
    5,533
    Jul 12, 2017
    0
    I would begin with engine managment cleaning and EGR cooler flush. Boost sensor is very common to get soot blocked and I agree can be a likely cause of low power. All sensors and tubes should be inspected and cleaned regularly. The higher the idle time and lighter the loads, the more frequent the cleanings will be needed.
     
    BoxCarKidd and spsauerland Thank this.
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted