Suppport Thread for the TND 500, TND 700 or future Rand McNally products.

Discussion in 'Trucking Electronics, Gadgets and Software Forum' started by Mark Kling, Apr 16, 2010.

Thread Status:
Not open for further replies.
  1. jmroadhog

    jmroadhog Medium Load Member

    443
    193
    Apr 26, 2012
    Grand Forks BC
    0
    PM Sent

    Thanks
    John
     
    Mark Kling Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. Mark Kling

    Mark Kling Technology Contributor

    10,935
    4,197
    Sep 23, 2007
    Statesville, NC
    0
    Taken care of.

    Thanks,
    Mark
     
  4. Balakov100

    Balakov100 Road Train Member

    3,934
    2,627
    May 10, 2012
    Temple, TX
    0
    Not sure if this is new or?.
    Don't remember last time I was in Cali..prolly before I got my TND 720...

    It's not showing the 55 Truck Limit in Cali.
     
  5. Mark Kling

    Mark Kling Technology Contributor

    10,935
    4,197
    Sep 23, 2007
    Statesville, NC
    0
    The 55 mph is not in the segments of the map database. It has been reported before.

    Thanks,
    Mark
     
  6. Forest

    Forest Bobtail Member

    17
    2
    Oct 4, 2007
    Quebec
    0
    Mark,
    Back in mid-summer 2013, I had issues with the TDN720 and the adaptor cable (known issue). I had the unit serviced on warranty by Rand; the power adaptor was swapped out for a new one. The actual unit wasn't touched from all appearances. Up to now this has worked but has once again started to show similar problems. Occasionally, the orange button doesn't respond, as if the spring to return the button to it's regular position is gone. Returning this unit repeatedly to the American service centre is not cheap; together with the customs paperwork lumped in. This unit would be considered off-warranty at this point but because this is a past know issue, what can Rand do?
     
  7. peterd

    peterd Medium Load Member

    344
    349
    Jan 7, 2012
    St.Catharines ON
    0
    Any state.I find it is quite common.Another common one is branch as in GW branch instead of GW bridge.I just laugh it of.
     
    Mark Kling Thanks this.
  8. icsheeple

    icsheeple Trailing the Herd

    2,548
    2,547
    Nov 1, 2013
    Kansas City, KS
    0
    I'm having problems pressing the screen on the 520. It doesnt give great feedback. For example I'll press something on the screen and nothing happens. Press again it will highlight but not respond. I have re-aligned the screen. It seems to work a little better on first startup, but almost unusable at times. I appreciate this thread and apoligize if this was already covered somewhere. Thanks.
     
  9. Mark Kling

    Mark Kling Technology Contributor

    10,935
    4,197
    Sep 23, 2007
    Statesville, NC
    0
    Sorry I have been offline the last 3 days. I was lucky enough to get food poisoning again (6 times now), so I was not in the best of health the last few days. I am almost an Un-zombie at this point and can actually connect two dots....:biggrin_2554:

    Thanks,
    Mark
     
  10. Mark Kling

    Mark Kling Technology Contributor

    10,935
    4,197
    Sep 23, 2007
    Statesville, NC
    0
    PM me with your name/E-Mail/serial number off the back and any information you have on the past repair.

    Thanks,
    Mark
     
  11. Mark Kling

    Mark Kling Technology Contributor

    10,935
    4,197
    Sep 23, 2007
    Statesville, NC
    0
    Her dock show LTM = Yes?

    Thanks,
    Mark
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Thread Status:
    Not open for further replies.