Thermoking SB-200 problem

Discussion in 'Trucks [ Eighteen Wheelers ]' started by forestcat, Aug 9, 2009.

  1. forestcat

    forestcat Bobtail Member

    18
    1
    Feb 21, 2009
    New York, NY
    0
    Hi Guys, I have a reefer with Thermoking SB-200 unit and during last couple weeks the engine would stop for no apparent reason. The fault codes are 63 and 84. I am hauling produce out from California to New York and during the last couple days it happened 4-5 times. Please help!
     
  2. Jim Bob

    Jim Bob Light Load Member

    183
    49
    Aug 2, 2009
    Portland, Or
    0
    The fault codes only mean that the engine stopped and it failed to restart.

    Check the fuel filter(s) or replace, you might have a clog in there. Also check the air filter for a clogged element.

    After that I would see if you got an intermittent short in the injection pump on/off switch.
     
    elpuft and forestcat Thank this.
  3. JR OTR

    JR OTR Light Load Member

    245
    149
    Jan 13, 2009
    0
    I had those same codes on a trailer I picked up about a month ago (older unit -- had something like 27,000 hours run time on it). Our maint guys were pretty sure it was either air in the fuel line or some sort of fuel issue (blockage, dirty fuel, etc.) and the TK guys fixed it up, though I don't know what they found.

    Good luck,

    Jim
     
    forestcat Thanks this.
  4. rookietrucker

    rookietrucker Trucker Forum STAFF Staff Member

    10,028
    6,910
    Jul 15, 2007
    TEXAS
    0
    pjw044, RAG, WallyGator and 1 other person Thank this.
  • Draft saved Draft deleted