TriPac APU Starts, runs for 30 seconds, then struggles.

Discussion in 'Heavy Duty Diesel Truck Mechanics Forum' started by earnies2, Aug 22, 2021.

  1. earnies2

    earnies2 Medium Load Member

    617
    210
    May 17, 2012
    Dedham, MA.
    0
    I have a tripac apu that when it starts in A/C mode. it starts runs fine for about 30 seconds then the A/C compressor will kick on and the engine will struggle for about a minute then run fine. When its struggling it puffes black smoke once it starts running fine the A/C compressor can kick on and off with no problems....
     
    truckdriver31 Thanks this.
  2. Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  3. jason6541

    jason6541 Road Train Member

    1,950
    3,692
    Mar 5, 2012
    Omaha, NE
    0
    Is it the older style Tri pac?. Or evolution,
    If older style turn throttle screw in to increase rpm about 100 rpm. Will not hurt the unit. It will not struggle as much and A/c compressor will turn a tad faster. Also is air filter clean?.
    A/c compressor puts a big strain on unit.
    Before anyone says it will hurt the unit. No it won’t thermo king dealers do it all the time on older non evolution APU
     
    earnies2 Thanks this.
  4. truckdriver31

    truckdriver31 Road Train Member

    6,453
    7,485
    Sep 18, 2013
    0
    is this only on cold starts. if so, start it on fan mode only. warm up engine and then turn to ac
     
    earnies2 Thanks this.
  5. earnies2

    earnies2 Medium Load Member

    617
    210
    May 17, 2012
    Dedham, MA.
    0
    Yes its a 2009 tripac I have already turned up the idle screw it was low i guess I could turn it up a little more. It sounds good when its running and the compressor kicks in it doesn't slow it down... just when it first starts up after that it cycles fine.
     
    truckdriver31 Thanks this.
  6. earnies2

    earnies2 Medium Load Member

    617
    210
    May 17, 2012
    Dedham, MA.
    0
    I will try that is there a setting that could be changed to delay the compressor turning on?
     
    truckdriver31 Thanks this.
  7. earnies2

    earnies2 Medium Load Member

    617
    210
    May 17, 2012
    Dedham, MA.
    0
    I forgot to post the air filter is changed every other month along with the fuel filter and the fuel screen. Every month I change the oil and filter
     
  8. bavarian

    bavarian Medium Load Member

    651
    663
    Feb 13, 2014
    Winnipeg
    0
    Why would you change oil and filters every month?

    The chances are, you have a problem in the fuel supply. Fuel poseibly draining back into the tank. Does your electric lift pump work? Itcstarts clicking about two seconds before the unit starts.
     
  9. earnies2

    earnies2 Medium Load Member

    617
    210
    May 17, 2012
    Dedham, MA.
    0
    I change the oil every month because I don't track hours and its cheep insurance. The electric fuel pump works fine the unit wouldn't start if the pump wasent working or the fuel drained back.. wich is not the problem it starts on the first crank and runs fine..
     
  10. truckdriver31

    truckdriver31 Road Train Member

    6,453
    7,485
    Sep 18, 2013
    0
    idk. i was just thanking of something
     
  • Truckers Report Jobs

    Trucking Jobs in 30 seconds

    Every month 400 people find a job with the help of TruckersReport.

  • Draft saved Draft deleted