Turbo or air cooler

Discussion in 'Trucks [ Eighteen Wheelers ]' started by Ladytrukr, Aug 24, 2017.

  1. Ladytrukr

    Ladytrukr Bobtail Member

    47
    14
    Aug 12, 2017
    0
    drivib my KW W900L today and I just heard a loud pop, and now I have black smoke coming from my truck... I also can't drive faster than 30 mph.... what did or am I doing wrong?
     
  2. gokiddogo

    gokiddogo Road Train Member

    8,360
    13,166
    Mar 5, 2012
    Ontario Canada
    0
    What year is your truck

    Black smoke is unburned fuel usually

    This would get more appropriate attention in the garage section.
     
    Ladytrukr Thanks this.
  3. TylerD

    TylerD Bobtail Member

    10
    10
    May 21, 2017
    Carolina
    0
    Pull over first safe spot. Pop your hood take a look.
     
    Ladytrukr Thanks this.
  4. Jace379

    Jace379 Light Load Member

    146
    96
    Mar 6, 2017
    0
    Air to air boot or intake line that goes to the compressor
     
    Ladytrukr Thanks this.
  5. Ladytrukr

    Ladytrukr Bobtail Member

    47
    14
    Aug 12, 2017
    0
    2006
     
  6. AModelCat

    AModelCat Road Train Member

    14,174
    55,182
    Jul 7, 2015
    The North
    0
    Popped intake pipe would be my first guess. Pretty easy to spot. Either that or the hood rubbed a hole in a rubber intake boot.
     
    fargonaz and Ladytrukr Thank this.
  7. Jace379

    Jace379 Light Load Member

    146
    96
    Mar 6, 2017
    0
    Or your turbo flew apart internally
     
    Ladytrukr Thanks this.
  8. Jace379

    Jace379 Light Load Member

    146
    96
    Mar 6, 2017
    0
    More then likely a boot popped though or the clamp broke or wasn't tight enough and the pipe blew off
     
    Ladytrukr Thanks this.
  9. Ladytrukr

    Ladytrukr Bobtail Member

    47
    14
    Aug 12, 2017
    0
    No hole in the intake boot, Going to check the intake pipe
     
  10. gokiddogo

    gokiddogo Road Train Member

    8,360
    13,166
    Mar 5, 2012
    Ontario Canada
    0
    Would this cause high egt also? With an electronic engine dumping more fuel in but not seeing the return in boost pressure in order to try to maintain rated power?
     
  • Draft saved Draft deleted